CloudBees CI on modern cloud platforms - Operations Center 2.176.4.3

Rolling release: 2019-09-25

Based on Jenkins LTS 2.176.4-cb-3

Initial release

Verified plugins

  • Async Http Client

    1.7.24.2 verifiedinstalled by default

  • Authentication Tokens API Plugin

    1.3 verifiedinstalled by default

  • Config File Provider Plugin

    3.5 verifiedoptional

  • Credentials Binding Plugin

    1.20 verifiedinstalled by default

  • Credentials Plugin

    2.3.0 verifiedinstalled by default

  • Display URL API

    2.3.1 verifiedinstalled by default

  • Folders Plugin

    6.9 verifiedinstalled by default

  • JUnit Plugin

    1.28 verifiedinstalled by default

  • Jackson 2 API Plugin

    2.9.9.1 verifiedinstalled by default

  • Javadoc Plugin

    1.5 verifiedoptional

  • Jenkins Mailer Plugin

    1.26 verifiedinstalled by default

  • Jenkins SSH Slaves plugin

    1.30.0 verifiedoptional

  • Kubernetes plugin

    1.18.3 verifiedoptional

  • LDAP Plugin

    1.20 verifiedoptional

  • MapDB API Plugin

    1.0.9.0 verifiedinstalled by default

  • Metrics Plugin

    4.0.2.5 verifiedinstalled by default

  • OWASP Markup Formatter Plugin

    1.6 verifiedoptional

  • Plain Credentials Plugin

    1.5 verifiedinstalled by default

  • SAML Plugin

    1.1.2 verifiedoptional

  • SCM API Plugin

    2.6.3 verifiedinstalled by default

  • SSH Credentials Plugin

    1.17.1 verifiedinstalled by default

  • Script Security Plugin

    1.63 verifiedinstalled by default

  • Secure Requester Whitelist Plugin

    1.2 verifiedoptional

  • Structs Plugin

    1.20 verifiedinstalled by default

  • Token Macro Plugin

    2.8 verifiedinstalled by default

  • Variant Plugin

    1.3 verifiedinstalled by default

Proprietary plugins

  • Beekeeper Upgrade Assistant Plugin

    2.138.0.10 proprietaryinstalled by default

  • CloudBees Administrative Monitors Plugin

    1.0.1 proprietaryinstalled by default

  • CloudBees Backup Plugin

    3.38.14 proprietaryinstalled by default

  • CloudBees Blue Ocean Default Theme

    0.5 proprietaryinstalled by default

  • CloudBees Castle Plugin - Core

    1.11.8.2 proprietaryoptional

  • CloudBees Castle Plugin - EBS backend

    1.11.8.2 proprietaryoptional

  • CloudBees Folders Plus Plugin

    3.8 proprietaryinstalled by default

  • CloudBees Jenkins Advisor Plugin

    2.9 proprietaryoptional

  • CloudBees Jenkins Enterprise License Entitlement Check

    8.23 proprietaryinstalled by default

  • CloudBees Jenkins Enterprise New User Experience

    1.2.22 proprietaryoptional

  • CloudBees License Manager

    9.35 proprietaryinstalled by default

  • CloudBees Monitoring Plugin

    2.8 proprietaryinstalled by default

  • CloudBees Nodes Plus Plugin

    1.17 proprietaryoptional

  • CloudBees PSE - Analytics Dashboards

    1.0.3 proprietaryoptional

  • CloudBees PSE Mesos Metrics Plugin

    1.0.3 proprietaryoptional

  • CloudBees PSE Project Configuration Info Plugin

    1.1.6 proprietaryoptional

  • CloudBees PSE Tenant plugin

    1.0.15 proprietaryoptional

  • CloudBees Plugin Usage Plugin

    1.10 proprietaryoptional

  • CloudBees Quiet Start Plugin

    1.5 proprietaryoptional

  • CloudBees Restart Aborted Builds Plugin

    1.12 proprietaryoptional

  • CloudBees Role-Based Access Control Plugin

    5.27 proprietaryinstalled by default

  • CloudBees SSH Build Agents Plugin

    2.3 proprietaryoptional

  • CloudBees Skip Next Build Plugin

    4.2 proprietaryoptional

  • CloudBees Support Plugin

    3.22 proprietaryinstalled by default

  • CloudBees Update Center Data API

    4.42 proprietaryinstalled by default

  • CloudBees Update Center Plugin

    4.46 proprietaryinstalled by default

  • CloudBees VMWare Autoscaling Plugin

    4.3.8 proprietaryoptional

  • CloudBees WikiText Security Plugin

    3.9 proprietaryoptional

  • External Notification Plugin

    1.2 proprietaryoptional

  • Kube Agent Management plugin

    1.1.15 proprietaryoptional

  • Master Provisioning Core

    2.2.9 proprietaryoptional

  • Master Provisioning Kubernetes

    2.2.9 proprietaryoptional

  • Master Provisioning Mesos

    2.2.9 proprietaryoptional

  • Notification API

    1.2 proprietaryoptional

  • Operations Center Agent

    2.176.0.1 proprietaryinstalled by default

  • Operations Center Analytics

    2.107.1.5 proprietaryoptional

  • Operations Center Analytics Configuration

    2.107.1.5 proprietaryoptional

  • Operations Center Analytics Feeder

    2.107.1.5 proprietaryoptional

  • Operations Center Analytics Kibana Dashboards

    2.107.1.5 proprietaryoptional

  • Operations Center Analytics Reporter

    2.107.1.5 proprietaryoptional

  • Operations Center Analytics Viewer

    2.107.1.5 proprietaryoptional

  • Operations Center Context

    2.176.0.6 proprietaryinstalled by default

  • Operations Center Elasticsearch Provider

    2.176.0.1 proprietaryinstalled by default

  • Operations Center Embedded elasticsearch

    2.73.0.1 proprietaryoptional

  • Operations Center JNLP Agent Controller Plugin

    2.176.0.2 proprietaryoptional

  • Operations Center Monitoring Plugin

    2.176.0.1 proprietaryinstalled by default

  • Operations Center Notification

    1.0 proprietaryoptional

  • Operations Center Server Cluster Operations

    2.176.0.1 proprietaryinstalled by default

  • Operations Center Server EC2 Cloud

    2.176.0.1 proprietaryoptional

  • Operations Center Server Kubernetes Cloud

    2.176.0.1 proprietaryoptional

  • Operations Center Server License Entitlement Check

    2.176.0.1 proprietaryinstalled by default

  • Operations Center Server Plugin

    2.176.0.6 proprietaryinstalled by default

  • Operations Center Server Role Based Access Control

    2.176.0.1 proprietaryoptional

  • Operations Center Single Sign-On Plugin

    2.176.0.1 proprietaryinstalled by default

  • Operations Center Update Center Plugin

    2.176.0.1 proprietaryinstalled by default

  • Palace Cloud Plugin

    2.0.11 proprietaryoptional

  • Palace Shared Cloud Plugin

    2.0.2 proprietaryoptional

  • User Activity Monitoring Plugin

    1.1.5 proprietaryoptional

Compatible plugins

  • Amazon EC2 plugin

    1.42.1 compatibleoptional

  • Amazon Web Services SDK

    1.11.562 compatibleinstalled by default

  • CloudBees AWS Credentials Plugin

    1.27 compatibleinstalled by default

  • CloudBees Flow

    1.1.9 compatibleoptional

  • Command Agent Launcher Plugin

    1.2 compatibleinstalled by default

  • Common API for Blue Ocean

    1.18.1 compatibleinstalled by default

  • Docker Commons Plugin

    1.15 compatibleoptional

  • Durable Task Plugin

    1.30 compatibleinstalled by default

  • Email Extension Plugin

    2.66 compatibleoptional

  • Favorite

    2.3.1 compatibleoptional

  • Form element path plugin

    1.8 compatibleinstalled by default

  • JAXB plugin

    2.3.0.1 compatibleinstalled by default

  • JavaScript GUI Lib: ACE Editor bundle plugin

    1.1 compatibleoptional

  • JavaScript GUI Lib: jQuery bundles (jQuery and jQuery UI) plugin

    1.2.1 compatibleoptional

  • Jenkins Active Directory plugin

    2.13 compatibleoptional

  • Jenkins Apache HttpComponents Client 4.x API Plugin

    4.5.5-3.0 compatibleinstalled by default

  • Jenkins JSch dependency plugin

    0.1.55 compatibleoptional

  • Jenkins Pub-Sub "light" Bus

    1.12 compatibleoptional

  • Kubernetes Credentials Plugin

    0.4.0 compatibleoptional

  • Matrix Authorization Strategy Plugin

    2.4.2 compatibleoptional

  • Matrix Project Plugin

    1.14 compatibleoptional

  • Maven Integration plugin

    3.4 compatibleoptional

  • Mock Security Realm

    1.3 compatibleinstalled by default

  • Node Iterator API Plugin

    1.5.0 compatibleinstalled by default

  • One-Shot Executor Plugin

    1.2 compatibleoptional

  • Oracle Java SE Development Kit Installer Plugin

    1.3 compatibleinstalled by default

  • PAM Authentication plugin

    1.4.1 compatibleoptional

  • Pipeline: API

    2.36 compatibleinstalled by default

  • Pipeline: Step API

    2.20 compatibleinstalled by default

  • REST API for Blue Ocean

    1.18.1 compatibleoptional

  • SSH Agent Plugin

    1.17 compatibleoptional

  • Server Sent Events (SSE) Gateway Plugin

    1.17 compatibleoptional

  • Stack Trace Suppression Plugin

    1.5 compatibleoptional

  • Support Core Plugin

    2.60 compatibleinstalled by default

  • Unique ID Library Plugin

    2.1.3 compatibleinstalled by default

  • View Job Filters

    1.27 compatibleinstalled by default

  • bouncycastle API Plugin

    2.17 compatibleinstalled by default

Plugin modifications

  • Jenkins LTS 2.176.4-cb-3

    Upgraded Jenkins LTS from 2.176.3-cb-6 to 2.176.4-cb-3

  • Release Notes

    Upgraded OWASP Markup Formatter Plugin from 1.5 to 1.6

  • Release Notes

    Upgraded CloudBees Assurance Plugin from 2.138.0.8 to 2.138.0.10

  • Release Notes

    Upgraded CloudBees License Manager from 9.34 to 9.35

  • User-scoped credentials (JENSEC-526)

    Upgraded Credentials Plugin from 2.2.0 to 2.3.0. Global and folder credentials were too broadly accessible for certain pipeline use cases, and user credentials were not well supported by pipelines. User-scoped credentials associate credentials to users with manual unlocking of these credentials so that sensitive credentials can be isolated to trusted phases of pipelines and to trusted users.

  • Release Notes

    Upgraded Kube Agent Management Plugin from 1.1.14 to 1.1.15

  • Release Notes

    Upgraded Kubernetes Plugin from 1.17.2 to 1.18.3

  • Release Notes

    Upgraded Mailer Plugin from 1.23 to 1.26

  • Release Notes

    Upgraded Operations Center Server Plugin from 2.176.0.4 to 2.176.0.6

  • Release Notes

    Upgraded Plain Credentials Plugin from 1.4 to 1.5

  • Release Notes

    Upgraded Variant Plugin from 1.2 to 1.3

  • User-scoped credentials updates (JENSEC-495)

    The Pipeline Input Step plugin has been updated to support the new Credentials API for binding credentials parameters to builds and supports user credentials as well as credential parameter name shadowing.

  • Support Internet Explorer 11 (NGPIPELINE-619)

    The Pipeline Stage View plugin now supports Internet Explorer 11.

  • Updates to the Backup plugin (CTR-429, CTR-428)

    Upgraded CloudBees Backup Plugin from 3.38.13 to 3.38.14. The Backup plugin included extraneous libraries that increased the artifact size unnecessarily. With this fix, we now exclude unnecessary dependencies from the httpclient artifact maven dependency.

The Backup plugin had an old version of common-compress as a dependency. With this fix, the Backup plugin has upgraded this out of date dependency.

Revision 2

Verified plugins

  • Ant Plugin

    1.10 verifiedoptional

  • Artifact Manager on S3 plugin

    1.6 verifiedoptional

  • Async Http Client

    1.7.24.2 verifiedinstalled by default

  • Authentication Tokens API Plugin

    1.3 verifiedoptional

  • Branch API Plugin

    2.5.4 verifiedoptional

  • Config File Provider Plugin

    3.5 verifiedoptional

  • Credentials Binding Plugin

    1.20 verifiedoptional

  • Credentials Plugin

    2.3.0 verifiedinstalled by default

  • Display URL API

    2.3.1 verifiedinstalled by default

  • Folders Plugin

    6.9 verifiedinstalled by default

  • GitHub Branch Source Plugin

    2.5.6 verifiedoptional

  • Gradle Plugin

    1.30 verifiedoptional

  • JUnit Plugin

    1.28 verifiedinstalled by default

  • Jackson 2 API Plugin

    2.9.9.1 verifiedinstalled by default

  • Javadoc Plugin

    1.5 verifiedoptional

  • Jenkins GIT server Plugin

    1.7 verifiedoptional

  • Jenkins Git client plugin

    2.7.7.1 verifiedoptional

  • Jenkins Git plugin

    3.12.0 verifiedoptional

  • Jenkins MSBuild Plugin

    1.29 verifiedoptional

  • Jenkins MSTestRunner plugin

    1.3.0 verifiedoptional

  • Jenkins Mailer Plugin

    1.26 verifiedinstalled by default

  • Jenkins SSH Slaves plugin

    1.30.0 verifiedoptional

  • Kubernetes plugin

    1.18.3 verifiedoptional

  • LDAP Plugin

    1.20 verifiedoptional

  • MapDB API Plugin

    1.0.9.0 verifiedinstalled by default

  • Metrics Plugin

    4.0.2.5 verifiedinstalled by default

  • OWASP Markup Formatter Plugin

    1.6 verifiedoptional

  • Plain Credentials Plugin

    1.5 verifiedoptional

  • SAML Plugin

    1.1.2 verifiedoptional

  • SCM API Plugin

    2.6.3 verifiedinstalled by default

  • SSH Credentials Plugin

    1.17.1 verifiedoptional

  • Script Security Plugin

    1.65 verifiedinstalled by default

  • Secure Requester Whitelist Plugin

    1.2 verifiedoptional

  • Structs Plugin

    1.20 verifiedinstalled by default

  • Token Macro Plugin

    2.8 verifiedinstalled by default

  • Variant Plugin

    1.3 verifiedinstalled by default

  • WMI Windows Agents Plugin

    1.4 verifiedoptional

Proprietary plugins

  • Beekeeper Upgrade Assistant Plugin

    2.138.0.10 proprietaryinstalled by default

  • CloudBees Administrative Monitors Plugin

    1.0.1 proprietaryinstalled by default

  • CloudBees Amazon AWS CLI Plugin

    1.5.10 proprietaryoptional

  • CloudBees Amazon Web Services Deploy Engine Plugin

    1.18 proprietaryoptional

  • CloudBees Backup Plugin

    3.38.14 proprietaryoptional

  • CloudBees Blue Ocean Default Theme

    0.5 proprietaryinstalled by default

  • CloudBees Even Scheduler Plugin

    3.9 proprietaryoptional

  • CloudBees Fast Archiving Plugin

    5.9 proprietaryoptional

  • CloudBees Folders Plus Plugin

    3.8 proprietaryinstalled by default

  • CloudBees Git Validated Merge Plugin

    3.25 proprietaryoptional

  • CloudBees Groovy View Plugin

    1.8 proprietaryoptional

  • CloudBees Jenkins Advisor Plugin

    2.9 proprietaryoptional

  • CloudBees Jenkins Enterprise License Entitlement Check

    8.23 proprietaryinstalled by default

  • CloudBees Label Throttling Plugin

    3.7 proprietaryoptional

  • CloudBees License Manager

    9.35 proprietaryinstalled by default

  • CloudBees Long-Running Build Plugin

    1.12 proprietaryoptional

  • CloudBees Monitoring Plugin

    2.8 proprietaryoptional

  • CloudBees Nodes Plus Plugin

    1.17 proprietaryoptional

  • CloudBees OpenShift CLI Plugin

    1.4 proprietaryoptional

  • CloudBees PSE Tenant plugin

    1.0.15 proprietaryoptional

  • CloudBees Pipeline (Deprecated)

    1.9.1 proprietaryoptional

  • CloudBees Pipeline Stage View Extensions

    2.3 proprietaryoptional

  • CloudBees Pipeline: Groovy Checkpoint Plugin

    2.7 proprietaryoptional

  • CloudBees Pipeline: REST API (Deprecated)

    1.9.1 proprietaryoptional

  • CloudBees Pipeline: Templates Plugin

    3.3 proprietaryoptional

  • CloudBees Plugin Usage Plugin

    1.10 proprietaryoptional

  • CloudBees Pull Request Builder for GitHub

    1.13 proprietaryoptional

  • CloudBees Quiet Start Plugin

    1.5 proprietaryoptional

  • CloudBees Restart Aborted Builds Plugin

    1.12 proprietaryoptional

  • CloudBees Role-Based Access Control Plugin

    5.27 proprietaryinstalled by default

  • CloudBees SSH Build Agents Plugin

    2.3 proprietaryoptional

  • CloudBees Skip Next Build Plugin

    4.2 proprietaryoptional

  • CloudBees Support Plugin

    3.22 proprietaryinstalled by default

  • CloudBees Template Plugin

    4.40 proprietaryoptional

  • CloudBees Update Center Data API

    4.42 proprietaryinstalled by default

  • CloudBees VMWare Autoscaling Plugin

    4.3.8 proprietaryoptional

  • CloudBees View Creation Filter Plugin

    1.5 proprietaryoptional

  • CloudBees WikiText Security Plugin

    3.9 proprietaryoptional

  • Kube Agent Management plugin

    1.1.15 proprietaryoptional

  • Managed Master New User Experience

    1.2.22 proprietaryoptional

  • Notification API

    1.2 proprietaryoptional

  • Operations Center Agent

    2.176.0.1 proprietaryinstalled by default

  • Operations Center Analytics Configuration

    2.107.1.5 proprietaryoptional

  • Operations Center Analytics Reporter

    2.107.1.5 proprietaryoptional

  • Operations Center Client Plugin

    2.176.0.4 proprietaryinstalled by default

  • Operations Center Cloud

    2.176.0.1 proprietaryoptional

  • Operations Center Context

    2.176.0.6 proprietaryinstalled by default

  • Operations Center Notification

    1.0 proprietaryoptional

  • Palace Cloud Plugin

    2.0.11 proprietaryoptional

  • Pipeline Event Step

    1.5 proprietaryoptional

  • Trigger Restrictions

    1.2 proprietaryoptional

  • User Activity Monitoring Plugin

    1.1.5 proprietaryoptional

Compatible plugins

  • AWS Global Configuration Plugin

    1.3 compatibleoptional

  • Amazon EC2 plugin

    1.42.1 compatibleoptional

  • Amazon Web Services SDK

    1.11.562 compatibleoptional

  • Autofavorite for Blue Ocean

    1.2.4 compatibleoptional

  • Azure PublisherSettings Credentials Plugin

    1.5 compatibleoptional

  • Bitbucket Branch Source Plugin

    2.4.4 compatibleoptional

  • Bitbucket Pipeline for Blue Ocean

    1.18.1 compatibleoptional

  • Blue Ocean

    1.18.1 compatibleoptional

  • Blue Ocean Core JS

    1.18.1 compatibleoptional

  • Blue Ocean Pipeline Editor

    1.18.1 compatibleoptional

  • CloudBees AWS Credentials Plugin

    1.27 compatibleoptional

  • CloudBees Docker Build and Publish plugin

    1.3.2 compatibleoptional

  • CloudBees Docker Hub/Registry Notification

    2.2.1 compatibleoptional

  • CloudBees Flow

    1.1.9 compatibleoptional

  • Command Agent Launcher Plugin

    1.2 compatibleinstalled by default

  • Common API for Blue Ocean

    1.18.1 compatibleinstalled by default

  • Conditional BuildStep

    1.3.6 compatibleoptional

  • Config API for Blue Ocean

    1.18.1 compatibleoptional

  • Configuration as Code Plugin

    1.27 compatibleoptional

  • Copy Artifact Plugin

    1.42.1 compatibleoptional

  • Dashboard View

    2.9.12 compatibleoptional

  • Dashboard for Blue Ocean

    1.18.1 compatibleoptional

  • Deployed On Column Plugin

    1.8 compatibleoptional

  • Deployer Framework Plugin

    1.2 compatibleoptional

  • Display URL for Blue Ocean

    2.3.0 compatibleoptional

  • Docker Commons Plugin

    1.15 compatibleoptional

  • Docker Pipeline

    1.19 compatibleoptional

  • Durable Task Plugin

    1.30 compatibleinstalled by default

  • Email Extension Plugin

    2.66 compatibleoptional

  • Events API for Blue Ocean

    1.18.1 compatibleoptional

  • External Monitor Job Type Plugin

    1.7 compatibleoptional

  • Favorite

    2.3.1 compatibleoptional

  • Form element path plugin

    1.8 compatibleinstalled by default

  • Git Pipeline for Blue Ocean

    1.18.1 compatibleoptional

  • GitHub API Plugin

    1.95 compatibleoptional

  • GitHub Pipeline for Blue Ocean

    1.18.1 compatibleoptional

  • GitHub plugin

    1.29.3 compatibleoptional

  • HTML Publisher plugin

    1.21 compatibleoptional

  • Handy Uri Templates 2.x API Plugin

    2.1.6-1.0 compatibleoptional

  • JAXB plugin

    2.3.0.1 compatibleinstalled by default

  • JIRA Integration for Blue Ocean

    1.18.1 compatibleoptional

  • JWT for Blue Ocean

    1.18.1 compatibleoptional

  • JavaScript GUI Lib: ACE Editor bundle plugin

    1.1 compatibleoptional

  • JavaScript GUI Lib: Handlebars bundle plugin

    1.1.1 compatibleoptional

  • JavaScript GUI Lib: Moment.js bundle plugin

    1.1.1 compatibleoptional

  • JavaScript GUI Lib: jQuery bundles (jQuery and jQuery UI) plugin

    1.2.1 compatibleoptional

  • Jenkins Active Directory plugin

    2.13 compatibleoptional

  • Jenkins Apache HttpComponents Client 4.x API Plugin

    4.5.5-3.0 compatibleinstalled by default

  • Jenkins Design Language

    1.18.1 compatibleoptional

  • Jenkins JIRA plugin

    3.0.9 compatibleoptional

  • Jenkins JSch dependency plugin

    0.1.55 compatibleoptional

  • Jenkins Mercurial plugin

    2.8 compatibleoptional

  • Jenkins Parameterized Trigger plugin

    2.35.1 compatibleoptional

  • Jenkins Pub-Sub "light" Bus

    1.12 compatibleoptional

  • Jenkins build timeout plugin

    1.18 compatibleoptional

  • Jenkins promoted builds plugin

    3.0 compatibleoptional

  • Kubernetes Credentials Plugin

    0.4.0 compatibleoptional

  • Matrix Authorization Strategy Plugin

    2.4.2 compatibleoptional

  • Matrix Project Plugin

    1.14 compatibleoptional

  • Maven Integration plugin

    3.4 compatibleoptional

  • Node Iterator API Plugin

    1.5.0 compatibleoptional

  • NodeJS Plugin

    1.2.9 compatibleoptional

  • One-Shot Executor Plugin

    1.2 compatibleoptional

  • Oracle Java SE Development Kit Installer Plugin

    1.3 compatibleinstalled by default

  • PAM Authentication plugin

    1.4.1 compatibleoptional

  • Personalization for Blue Ocean

    1.18.1 compatibleoptional

  • Pipeline

    2.5 compatibleoptional

  • Pipeline Graph Analysis Plugin

    1.10 compatibleoptional

  • Pipeline SCM API for Blue Ocean

    1.18.1 compatibleoptional

  • Pipeline implementation for Blue Ocean

    1.18.1 compatibleoptional

  • Pipeline: API

    2.36 compatibleinstalled by default

  • Pipeline: Basic Steps

    2.18 compatibleoptional

  • Pipeline: Build Step

    2.9 compatibleoptional

  • Pipeline: Declarative

    1.3.9 compatibleoptional

  • Pipeline: Declarative Agent API

    1.1.1 compatibleoptional

  • Pipeline: Declarative Extension Points API

    1.3.9 compatibleoptional

  • Pipeline: GitHub Groovy Libraries

    1.0 compatibleoptional

  • Pipeline: Groovy

    2.73 compatibleoptional

  • Pipeline: Input Step

    2.11 compatibleoptional

  • Pipeline: Job

    2.33 compatibleoptional

  • Pipeline: Milestone Step

    1.3.1 compatibleoptional

  • Pipeline: Model API

    1.3.9 compatibleoptional

  • Pipeline: Multibranch

    2.21 compatibleoptional

  • Pipeline: Nodes and Processes

    2.33 compatibleoptional

  • Pipeline: REST API Plugin

    2.12 compatibleoptional

  • Pipeline: SCM Step

    2.9 compatibleoptional

  • Pipeline: Shared Groovy Libraries

    2.15 compatibleoptional

  • Pipeline: Stage Step

    2.3 compatibleoptional

  • Pipeline: Stage Tags Metadata

    1.3.9 compatibleoptional

  • Pipeline: Stage View Plugin

    2.12 compatibleoptional

  • Pipeline: Step API

    2.20 compatibleinstalled by default

  • Pipeline: Supporting APIs

    3.3 compatibleoptional

  • REST API for Blue Ocean

    1.18.1 compatibleoptional

  • REST Implementation for Blue Ocean

    1.18.1 compatibleoptional

  • Run Condition Plugin

    1.0 compatibleoptional

  • SSH Agent Plugin

    1.17 compatibleoptional

  • Server Sent Events (SSE) Gateway Plugin

    1.17 compatibleoptional

  • Stack Trace Suppression Plugin

    1.5 compatibleoptional

  • Support Core Plugin

    2.60 compatibleinstalled by default

  • Unique ID Library Plugin

    2.1.3 compatibleinstalled by default

  • Web for Blue Ocean

    1.18.1 compatibleoptional

  • bouncycastle API Plugin

    2.17 compatibleinstalled by default

  • i18n for Blue Ocean

    1.18.1 compatibleoptional

  • jQuery plugin

    1.12.4-0 compatibleoptional

Plugin modifications

  • Release Notes

    HTML Publisher plugin upgraded from version 1.16 to version 1.21

  • Release Notes

    Script Security Plugin upgraded from version 1.63 to version 1.65