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ElectricInsight
Introduction

Until now, there has been little visibility into builds to “see” why a build was slow, why a build broke, or 
which dependencies were involved. ElectricInsight® removes the “black box” around software product 
builds and provides easy-to-understand performance data.

About ElectricInsight
ElectricInsight depicts how a build is structured and run, empowering build managers to pinpoint 
performance problems or conflicts in a parallel build. Developed to work with ElectricAccelerator®, 
ElectricInsight mines information produced by Electric Make® to provide an easy-to-understand, 
graphical representation of the build structure for performance analysis.

ElectricInsight provides detailed information and reports for at-a-glance diagnostics for each job on each 
host in the build cluster. Users can identify which jobs are performing, when, and with which files. 
Instead of manually reading through tens of thousands of lines of information in log files, error detection 
and performance tuning that used to consume hours or days can now occur in a few minutes or seconds.

By observing and tracing serialization sources or slowdowns, you can fine tune your build for maximum 
speed. ElectricInsight gives you the ability to pinpoint areas to improve in your build process—and you 
will have answers for these questions:

• Are any unnecessary serializations occurring?

• Is there a gap where one or more agents is not busy?

• Which job chains are the longest and can they be shortened?

• Which files are being modified (created, updated, or deleted) multiple times?
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Getting Started

Annotation
ElectricInsight gathers information from build annotation files to create a picture of your build. To use 
ElectricInsight, you must run your builds with the --emake-annodetail parameter. For 
sophisticated analysis of builds, run Electric Make (eMake) with file, history, and waiting 
level annotation.

Set annotation levels using custom build classes or the eMake command line:

% emake ... --emake-annodetail=file,waiting,history ... 

Collecting annotation information may cause your build to run approximately 5% slower.

Supported annotation detail levels:

Note: For additional information about annotation, see the “Annotation” chapter in the Electric Cloud 
Electric Make Users Guide.

Annotation File Splitting

Due to a gcc file size write limit, annotation file size is limited to 1.6 GB. Large annotation files are split 
to remain under this limit. This limit is not configurable.

ElectricInsight requires a single annotation file. To rejoin split annotation files:

On Linux: 

cat file1 > result_file
cat file2 >> result_file

basic detailed information about each “job” in the build, including command arguments, 
output, exit code, timing, and source location

env environment variable modification information (ElectricAccelerator 4.3 and later)

file filesystem operations information, excluding lookups

history information about implicit dependencies discovered by Electric Make 

lookup filesystem operations information, including lookups  

registry registry operations information (ElectricAccelerator 4.3 and later)

waiting information required to reconstruct the complete dependency graph
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Getting Started
On Windows:

type file1 > result_file
type file2 >> result_file

Note: Though there is no predetermined limit at which an annotation file cannot be loaded by 
ElectricInsight, the maximum size is limited by the size of the process because ElectricInsight is a 32-bit 
application.

Starting ElectricInsight
To start ElectricInsight, go to Start > All Programs > Electric Cloud > ElectricInsight, or type “einsight” 
at the command prompt. You can specify the target build annotation file if you want.

% einsight [build-annotation-file]

When ElectricInsight starts, it displays your build information. 

If you did not specify a build annotation file on the command line, browse for one to load. Click the 
folder icon on the toolbar or select File > Load annotation.

Navigate to the annotation file of a completed build you want to analyze and click Open. This displays 
your build.
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Getting Started
Navigating ElectricInsight
The following sections will familiarize you with the ElectricInsight interface.

Agents & Jobs

In the Agents & Jobs section (outlined in the following screenshot), each agent used in the build is 
represented by one row. Host names and agent number designations appear to the left of the agent job 
bars. Use the view frame and arrows in the Navigation section to view agents that are not currently 
visible.

The section’s x-axis is time, with the build starting at the left. The first job completed by each agent is at 
the extreme left of an agent’s job bar. As you scroll to the right on an agent’s job bar, you see the progress 
of jobs assigned to the agent.

The time grid helps you determine how long jobs take. The grid has major and minor grid lines. By 
default, major grid lines are 60 seconds (pixels) apart and minor grid lines are 15 seconds (pixels) apart. 
Build magnification is measured in pixels per second (pps). As you zoom in or out, this ratio increases or 
decreases. Magnification is displayed in the lower right corner.

To see how long some jobs took to complete, click and drag from the left edge of the first job to the end 
of the last job of interest. The job ruler appears and displays a time measurement. You can also use the 
ruler by dragging from right to left.
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Getting Started
Navigation

In the Navigation section, the view frame indicates which part of the build is displayed. If the entire build 
is displayed, the view frame is the same size as the scroll bar. Drag the frame to view different build 
stages. You can also use the arrows on either side of the navigation bar to move the view frame.

Below the Navigation section is a field showing how long it took ElectricInsight to load build annotation 
information.
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Getting Started
Overview

The Overview section displays the following build information:

• Build ID and whether it was successful

• Build duration

• Number of makes in the build

• Number of agents and hosts used by the build

• Number of jobs in the build

• Annotation details collected in the build

Keep in mind the following terminology:

• Each makefile has one or more rules (lines of text). 

• A target is the rule output. 

• A command is a single shell invocation in a rule. 

• A job corresponds to a rule scheduled as part of a build—in most cases. 

• Also, there are jobs that parse a makefile. Jobs also have status—possible status values include 
normal, conflict, rerun, reverted, and skipped. For more details about job status, see “Supported 
Search Fields” on page 3-9.

Note: To hide the Overview, Legend, and Job Summary sections, click the gray bar between those 
sections and the Agents & Jobs section. Click it again to show the hidden sections.
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Legend

The Legend section displays the total number of jobs for each type and status within the build. Click a 
job type or status to list all of its instances within the build. Legend colors correspond to the job type and 
status for individual jobs within agent job bars. 

The Agents & Job section displays two dimensions of job data—job status and job type. If the job status 
is not unusual (for example, the job was scheduled and ran normally), then the job type (such as parse or 
rule) only is displayed. If a job has an unusual status (such as conflict or reverted), that color is used for 
the lower portion of the job and the upper portion retains the color of the job type. 

The presence of conflict and reverted jobs means the build was slower than necessary. Reverted jobs are 
symptoms of job conflicts. To eliminate reversions, you must eliminate conflicts. Usually, running a 
build with a history file eliminates conflicts. Typically, the most expensive job conflicts are those 
involving parse jobs.

If your build ran without a history file, you may have conflicts. If you had a pre-existing history file, your 
build should not contain conflicts unless the build changes affected job order and inter-dependencies.
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Getting Started
Job Summary

To display a job’s summary information, mouse over any job in an agent job bar. The selected job is 
outlined in pink in the agent job bar.

The Job Summary section displays the following information about the selected job:

• Job ID and job type or status (for additional information about job types and status, see “Supported 
Search Fields” on page 3-9)

• Start time (as an offset from the build start time)

• End time

• Job length in hours/minutes/seconds

• Output target name
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Dependencies and Waiting Jobs Popup

In the Agents & Jobs section, right-clicking a job that has dependencies or waiting jobs displays a popup 
menu. You can select Show dependencies or Show waiting jobs. Dependencies are outlined in blue. 
Waiting jobs (not shown in the screenshot) are outlined in red. 

To find dependencies or waiting jobs, load an annotation file containing waiting and history level 
annotation and run the Serialization analysis report.

Zoom

The Tools menu contains the following magnification options:

• Zoom in

• Zoom out

• Zoom to...

• Zoom to fit

Zoom to... - this option allows you to specify a magnification factor for the display. To return to the 
initial, unzoomed view, select Tools > Zoom to... and type a zoom factor of 1.0.

Zoom to fit - this option sizes the display to fit the available space. Doing this may leave empty space to 
the left of all agent job bars, which depicts the time when eMake was parsing the makefile, before agents 
were assigned jobs. It is also possible that agents you are not currently viewing were working while 
agents you are viewing were not assigned to this build.

You can also zoom in or out using the magnifying glass icons in the toolbar or by pressing 
CTRL-[equal sign] or CTRL-[minus sign].
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Replay Build

ElectricInsight enables you to replay your build in the Agents & Jobs section, allowing you to observe its 
progress. You can display the replay toolbar by clicking Replay > Show toolbar in the main menu. The 
following screenshot shows the replay toolbar and a build replay in progress.

Replay controls:

• Play - starts the replay.

• Fast forward - increases replay speed. You can click fast forward up to three times to speed up the 
replay. Clicking a fourth time returns the speed to normal.

• Pause - pauses the replay. Click play to start again.

• Stop - stops the replay.
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Monitor Live Build

ElectricInsight enables you to monitor a live build in the Agents & Jobs section. 
Select File > Monitor live build in the main menu to display the following dialog.

Provide the host and port information from the --emake-monitor command-line option and click 
OK.
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Build, Job, and Make
Information

Build Properties
To view overall build properties, click File > Build Properties. There are three tabs: Properties, 
Environment, and Performance Metrics. 

The Environment tab displays build environment information, which you can copy to the clipboard:

1. Right-click anywhere in the window

2. Select Copy to clipboard

3. Select ...for bash/ksh or ...for cmd
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Build, Job, and Make Information
Job Details
This section provides additional information about jobs and the Job Details dialog.

To open the Job Details dialog, double-click a job in an agent job bar, or select a job and press 
CTRL-Enter. The Job Details tab is displayed by default. 

Job Details Tab

This tab displays summary information about the job. The following fields contain the same information 
as they do on the main ElectricInsight screen: ID, Type, Start, End, and Length.

For some types of jobs, the Target name, Makefile, and Output fields are populated. When the Output 
field is filled in, you can enable Show commands to see the makefile line(s) that correspond to the job.

The Makefile field identifies the makefile and the relevant line in that makefile that created the job. You 
can click the makefile to open it in an editor. The Makefile field is empty for parse-type jobs because 
parse jobs are not created from a line in a makefile; for example, there is no rule in the makefile that 
instructs eMake to parse the makefile. To find which makefile a job parses, refer to the Directory and 
Name columns in the Job Path tab.

For a job that started a recursive make, the Job Details dialog contains a Submakes tab listing recursive 
makes arising from the job. Double-click an entry in the list to display the job’s detail dialog.

To search the Output field, press CTRL-F. CTRL-G finds the next occurrence.
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Job Path Tab

The Job Path tab displays the path to the makefile line(s) that created the job. The first line contains the 
command invoking the top level makefile. Typically, this line invokes another makefile. If it does, the 
second line displays the job ID. If it does not invoke another makefile, the second line displays the name 
of the target the job executes.

If the makefile line that created the job invoked a second makefile, this pattern of makefile lines and job 
IDs is repeated, chaining through makefiles until the target that created the job is reached.

Environment Tab

The Environment tab is available only if your annotation file includes env level annotation.

This tab displays environment information that was used to run the job. You can copy this information to 
the clipboard:

1. Right-click anywhere in the window

2. Select Copy to clipboard

3. Select ...for bash/ksh or ...for cmd
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Annotation Tab

The Annotation tab displays the portion of the annotation file pertaining to the job.

Press CTRL-F to search for and highlight text. CTRL-G finds the next occurrence.
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Submakes

The Submakes tab is available if the job includes submakes. This tab lists all submakes that the job runs, 
including their ID, Directory, and Command line make command.

Viewing All Jobs

To list all of the build’s jobs from the main ElectricInsight window, select Tools > View all jobs....
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Make Details
This section provides additional information about the Make Details dialog.

To open the Make Details dialog, double-click a make command, for example, in the Job Path tab of the 
Job Details dialog. The Make Details tab is displayed by default.

Make Details Tab

This tab displays information about the make. The tab has the following fields: ID, Level, 
Emulation mode, Directory, and Command line.
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Make Jobs Tab

The Make Jobs tab lists all jobs that the makefile runs.

Make Path Tab

The Make Path tab displays the path to the makefile line(s) that created the make. The first line contains 
the command invoking the top level makefile. Typically, this line invokes another makefile. If it does, the 
second line displays the job ID. If it does not invoke another makefile, the second line displays the name 
of the target the job executes.
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Build, Job, and Make Information
Searching for Jobs
If you know the job ID, use Tools > Find job by ID to go to job details.

If you do not know the job ID, you can search for jobs using several criteria. Select Tools > Search jobs, 
or click the binoculars icon on the toolbar to display the search dialog.
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Type-in the strings you want to search for (for example, “gcc conflict”) and click Search. The values 
come from fields in the build annotation file. You can constrain your search by searching for specific 
values in specific fields. 

To sort your results, select an option from the drop-down. Double-click a row to display a job’s Job 
Details dialog. In the dialog’s lower-right corner, click Go to job. The job is now highlighted in the 
Agents & Jobs section.

If you want to view all jobs and do not want to search, select Tools > View all jobs to display all build 
jobs sorted in serial order.

Supported Search Fields

The following fields are supported:

• name - the name of a job is the name of the target that created it. Continuation and parser jobs do not 
have names. 

• commands - search makefile command lines and output. Globbing patterns are supported (for 
example, commands:gcc *foo*).

• status - possible values include:

• normal - a successfully run job

• conflict - a job involved in a conflict. Many of these jobs or jobs on which they rely are reverted. 
Typically, conflicts occur when there is no history file—when the environment does not provide 
Electric Make with enough information to predict all job dependencies.

• rerun - some reverted jobs must be run with correct file system context. Rerun jobs are always 
serialized to guarantee correct context.

• reverted - a job is reverted when Electric Make serializes job results and the job in question was 
executed before a (logically) preceding job that failed. The preceding job may have failed 
because of a conflict. Reverting a job restores the Agent’s file system to the state before the job 
was run.

• skipped - skipped jobs are the same as reverted jobs except the skipped job did not run before 
the preceding job failed.

• type: possible values include:

• continuation - a continuation job occurs when commands associated with a makefile target 
include a submake (also known as, recursive make). Typically, these submake commands begin 
with $(MAKE). The commands below a submake, down to and including the next submake 
command (for the same target), comprise a continuation job. For a target, there are as many 
continuation jobs as there are submakes with commands after them.

all:
echo abc
$(MAKE) abc
echo def
echo ghi
$(MAKE) ghi
echo jkl
$(MAKE) jkl

In this example, the first continuation job starts with echo def and ends with $(MAKE) 
ghi. The second and last continuation job consists of two commands involving jkl.

• end - clean-up tasks that occur at the end of makefiles (for example, removing intermediate 
files).

• exist - jobs corresponding to top-level targets without rules. Electric Make verifies the target 
exists.

• follow - one of these jobs follows every submake to handle submake output and exit status for 
the parent.

• parse - jobs that parse makefiles.

• remake - jobs that remake makefiles (only for GNU make).
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• rule - lists jobs corresponding to makefile rules. Sorting results by name allows you to find the 
job that executed a specific rule. If you have several rules (in different makefiles) with the same 
name, you can display several Job Details dialogs at once.

• make - this is the ID of the makefile that created the job. The top-level makefile has ID 0 (zero). For 
example, make:0 returns a list of jobs created directly from the top-level makefile.

• job - the job ID (for example, job:J01b11200)

• neededby - the job in question is needed by another job. Specify the job ID of the job that needs the 
job in question (for example, neededby:J01b11200). This is useful for tracking inter-job 
dependencies.

• length - job length, in seconds. If you specify length:12.34, you get jobs that lasted exactly 
12.34 seconds only. You can also search using length:>12.34, length:>=12.34, 
length:==12.34, length:<12.34, and length:<=12.34. To find jobs that lasted 10-15 
seconds, specify length:>=10.0 length:<=15.0.

• exitcode - the job exit code. To find jobs with a non-zero exit code use exitcode:!=0. In 
general, use arithmetic relations (=, >, <, >=, <=) to search numerical values and use no relation 
symbols when searching for string values.

• waitingJobs:<jobID> - to find prerequisite jobs of <jobID>.

• start - job start time (in seconds) after the build start time. To find other jobs that started in the first 
minute of the job, use start:<60. To find jobs that took more than 60 seconds and started during 
the 10th minute into the build, type length:>60 start:>=600 start:<660.

• finish - the job end time (in seconds) after the build start time.

• restarts - lists jobs restarted a specified number of times. Jobs are restarted because of cluster sharing 
and agent failure.

You can restrict the search scope for the following fields only: type, status, name, make, and job.

Search Examples
To find rule jobs involved in conflicts, search for

rule conflict or type:rule status:conflict

To find conflicts involving jobs named “export” search for

conflict name:export

To find rerun jobs with names including “port” search

rerun name:*port*

To search for non-reverted jobs with names ending in “Makefile” search

!reverted name:*Makefile
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ElectricInsight
Reports

About Reports
To display the Reports dialog, select Tools > Reports or click the reports icon on the toolbar. You can 
open one report at a time only for each ElectricInsight instance, but you can open several ElectricInsight 
instances.

You can run most reports by double-clicking the report name. Exceptions are Serialization analysis and 
ElectricSimulator, which have mandatory parameters.

The following reports are available:

• Build manifest

• Cluster sharing

• Derived files analysis

• ElectricSimulator

• Files modified multiple times

• Job count by length

• Job time by length

• Job time by type

• Jobs by agent

• Jobs by file

• Longest jobs

• Longest serial chain

• Makefile manifest

• Root conflicts

• Serialization analysis
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ElectricInsight Reports
Build manifest

The Build manifest report lists all files that were read and/or written by the build. This report can help to 

• Verify that all files read by the build are the latest version from source control

• Add all files written by the build to an archive

• Produce a list of all inputs and a list of all outputs

• Identify files that are written but never read

This report requires

--emake-annodetail=basic,file

To export the report to a .csv file, click Export.

To run a shell command, click Run Command. Type a command and a pathname in the Run Shell 
Command dialog. The the shell command is run with each file in the filtered list as an argument. Results 
and errors are displayed under their corresponding tabs.
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Cluster sharing

The Cluster sharing report shows the total work time lost (sum of aborted job run-times) and net build 
time lost (total work time minus overlaps) due to cluster sharing over the lifetime of the build.

For example: job A starts 5 seconds into the build and job B starts 10 seconds into the build. Both jobs 
are terminated 20 seconds into the build. The total work time lost is 15 + 10 seconds, but the net build 
time lost is 15 seconds only because the build time lost by B overlaps the build time lost by A.

This report is useful if your build aborts jobs because an agent host is de-allocated from the build. The 
host may have been allocated to another build, moved to another cluster, or simply shut down. The 
aborted jobs must be rerun, resulting in a slower build. 

This report does not consider the effect of not using some agent hosts because other builds are using 
them. To evaluate this factor, use the ElectricSimulator report.
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Derived files analysis

The Derived files analysis report allows you to view a specified file’s affected outputs. For example, this 
report answers the question, “If I change file X, what outputs will be affected?” A file is likely to be 
affected if it is produced concurrently with, or subsequent to, reads of the specified file. 

This report requires

--emake-annodetail=file,history

To run the report, enter the file(s) (with full paths) in the input field and click Run.

The middle display area lists the files that will change when the input file changes. Double-click a file in 
this list to display its chain of operations in the lower display area. Double-click an item in this lower 
display area to display its Job Details dialog.

Click Clear to clear all fields.

Click Copy Report to copy the displayed chain of operations (in the lower display area) to the 
clipboard.
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ElectricSimulator

The ElectricSimulator report predicts build performance on a variety of cluster sizes. 

This report requires

--emake-annodetail=waiting

Fill in the fields and click Run.

Minimum agents - the minimum number of agents with which to run the simulation.

Maximum agents - the maximum number of agents with which to run the simulation.

Step size - the number of agents to increment the count each time.

Note: The simulator time results are estimates only. They do not indicate guaranteed performance.

The last time indicator (blue bar) is the minimum possible build time.
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Files modified multiple times

This report shows which files are modified (created, updated, or deleted) multiple times during a build. 
Jobs involving these files require careful serialization to ensure the file operations sequence is performed 
in the correct order.

This report requires

--emake-annodetail=file

After you run the report, filter the results. In the Filter field, type the string you want to filter for and 
press Enter.

Use an asterisk to match any number of characters and use a question mark to match any single character.

Simple regular expressions are also supported. For example, *[xz].o and *[x-z].o are supported.

Filters are case sensitive.
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Job count by length

This bar chart shows jobs grouped into different length ranges. Each bar is color-coded to show the 
proportion of jobs for each job length.

By default, the second bar (and succeeding bars) count the unique jobs in that time range only. Therefore, 
the bar labeled 0.50s shows only jobs that took less than 0.50s but more than 0.25s. In the preceding 
chart, however, Show cumulative sums is enabled.
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Job time by length

This bar chart shows how total build time is consumed by different length jobs. While the Job count by 
length report shows your build has a large number of very short jobs, this report shows which job length 
consumes the largest part of the build. Bars are color-coded to show which job types use the most time. 
The Show cumulative sum toggle allows you to see cumulative statistics.
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Job time by type

This treemap shows the portion of total job time consumed by each job type. The area covered by each 
color is proportional to the total time consumed by its corresponding job type.

The legend displays corresponding colors for job types. The following information is available:

• Category
• Time (s)
• % of total
• # jobs
• Average (s)

Note: To sort data, click a column heading.

Clicking a row outlines the corresponding area in the treemap in yellow and lists all jobs of that type in 
the Jobs section. Double-clicking a job from the list displays the job’s details. You can also display all 
jobs of a specific type by clicking an area of the treemap.
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Jobs by agent

The Jobs by agent report lists the number of jobs run by each agent in the build. Click an agent to display 
the jobs that it ran. Double-click a job to display its details.

Jobs by file

The Jobs by file report lists which jobs read or wrote a particular file.

Type in or browse to the file you want to analyze and click Analyze.
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Longest jobs

This report lists the build’s 10 longest jobs. 

To view the Job Details dialog, double-click a job ID.
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Longest serial chain

This report displays the sequence of serialized jobs with the longest end-to-end runtime in the build.  
This represents a lower bound on the build runtime. Without changing the structure or content of the 
build, the runtime cannot be less than the longest serial chain. 

You can display the longest serial chain overall or the longest serial chain leading to a specific job.

This report requires 

--emake-annodetail=waiting,history

To display the Job Details dialog, double-click a job.
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Makefile manifest

This report lists all makefiles used in the build. To export the list to a file, click Export. 
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Root conflicts

This report lists all root conflicts in the build.

A root conflict is a conflict that was not cause by an earlier conflict. ElectricInsight divides all conflicts 
found in a build into two categories:

• root conflicts

• conflicts resulting from earlier conflicts (for example, jobs that are in conflict with jobs that are 
rerun jobs)
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Serialization analysis

This report can detail dependencies between a pair of jobs. For example, you want to know what jobs are 
waiting for after you look at the Annotation tab and see that the job has waitingJobs.

This report requires 

--emake-annodetail=waiting,history

and works best with 

--emake-annodetail=waiting,history,registry

Type the ID of the job you started first in the first job field; type the ID of the waiting job in the second 
job field, and click Locate Dependency.

If you know where the jobs [of interest] appear in the main jobs display, use the buttons next to the job 
fields to select the jobs.

In some cases you can use this report to understand the longest serial chain, but dependencies may exist 
that are not within the scope of the Serialization analysis report. For example, it is common for a rule job 
to be preceded by a parse job. This type of logical dependency is not included in the Serialization 
analysis report.
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Creating Custom Reports
You can create custom reports and make them accessible in ElectricInsight.

Example: Creating a report to display the number of jobs run by each agent used in the 
build
A report typically consists of a single .tcl source file containing Tcl code required to perform build 
annotation analysis as well as the Tk code required to display the result in the ElectricInsight UI.

Directories

On startup, ElectricInsight scans the directories listed below for .tcl files defining new reports. You 
can save your report in either location and ElectricInsight automatically includes the report the next time 
it starts.

Linux directories:

• /opt/ecloud/ElectricInsight/reports

• $HOME/.ecloud/ElectricInsight/reports

Windows directories:

• c:\ecloud\ElectricInsight\reports

• $USERPROFILE\Electric Cloud\ElectricInsight\reports

Reports saved in the Electric Cloud directories listed above are available to all users running 
ElectricInsight. Reports in other locations are available to a single user only.

Scripts

1. The Tcl script must declare the report to ElectricInsight using the DeclareReport API, which takes 
three arguments:

• The report name - the name displayed in the reports list in the ElectricInsight Reports dialog.

• The name of the user-defined function invoked to create the report.

• A report description - this description is displayed in the Description field of the ElectricInsight 
Reports dialog when the user clicks the report name.

For example:

DeclareReport “Jobs by agent” CreateJobsByAgentReport {
Count the jobs run by each agent.}

2. The Tcl script contains the function to perform the analysis and display results. The function is 
invoked with two arguments:

• The name of the “widget” the function needs to create to display results.

• The name of the variable the function needs to update with progress information, from 0.0 to 
1.0. This information controls the “progress bar” when the report is generated.

proc CreateJobsByAgentReport {w progressVar} {

In addition to function arguments, a global variable anno is available for reports. This is a handle 
for the annolib object containing build annotation information currently loaded in ElectricInsight. 
To access this information in your report, import the anno variable: global anno
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3. Write the Tcl code to perform the analysis on the annotation information:

    # Iterate through all the jobs in the build, counting
    # the number of jobs run by each agent.

    array set count {}
    $anno jobiterbegin
    while { [$anno jobitermore] } {
        set job [$anno jobiternext]
        set agent [$anno job agent $job]
        if { $agent ne ““ } {
            if { [info exists count($agent)] } {
                incr count($agent)
            } else {
                set count($agent) 1
            }
         }
     }

4. Write the Tk code to display results. ElectricInsight includes the [Tile] widgets and the 
[Tablelist] widget. For this report, a simple tablelist can display the results:

# The “count” array contains the number of jobs run by  
    # each agent. 
    # We create a simple tablelist (multi-column listbox) 
    # to display the results.

    frame $w
    ttk::label $w.label -text “Jobs by agent:” -anchor w
    tablelist::tablelist $w.results -columns {
        0 “Agent”
        0 “Jobs run by this agent”
    }   -height 10 -width 80 -borderwidth 1 -stretch end \
        -font TkDefaultFont -background gray98 \
        -stripebackground \#e0e8f0 \
        -labelcommand tablelist::sortByColumn
    $w.results columnconfigure 1 -sortmode integer
    grid $w.label -sticky ew
    grid $w.results -sticky nsew
    grid columnconfigure $w 0 -weight 1
    grid rowconfigure $w 1 -weight 1

    foreach agent [lsort [array names count]] {
        $w.results insert end [list $agent $count($agent)]
    }
    return $w

 } 
 # end of procedure CreateJobsByAgentReport

If you develop a report, you do not need to restart ElectricInsight to reload your report. Instead, select 
Tools > Reload reports.
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Using ElectricInsight to
Increase Build Speed

Identifying Build Issues
Using ElectricInsight to understand build performance can help you to identify and solve issues that 
provide the largest performance gains.

At a minimum, specify annodetail as basic. Additional detail levels enable more sophisticated 
analysis of the build. For maximum performance analysis, set annodetail to 
“basic,lookup,waiting,history,registry”. Because additional information may affect 
performance slightly, specify basic level detail only, unless you are actively pursuing a performance 
issue. 

When viewing an annotation file in ElectricInsight, you can see if your build is slow due to excessive 
conflicts, over serializations, or insufficient decomposition of build steps. You can then drill-down into 
job details by double-clicking individual jobs in the Agents & Jobs section. 

Use the Longest serial chain report to help estimate the best possible performance you can reasonably get 
from the build. Use the Serialization analysis report to understand why jobs are serialized. In an optimal 
parallel build, all agents are busy at the same time.
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For example, the image on the left shows a build that suffers from over serialization. Using the 
Serialization analysis report, you can determine why the build is serialized and adjustment the build to 
eliminate serializations. The image on the right shows the result.

Additionally, when examining the Agents & Jobs section, watch for the following:

• one agent bar is longer than others

• if there are gaps when an agent is not running a job, carefully examine the running jobs while some 
agents are idle
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Annolib Programmer’s
Reference

Annolib
annolib is the library used to parse annotation files.

anno create Create a new anno object that can be used to query information from an 
annotation file. The return value is a handle which can be used in subsequent 
[$anno ...] call. For example:

set anno [anno create]
$anno agents

$anno agents Retrieve a list of agents that participated in this build.

$anno comparejobs field jobId jobId Compare two jobs for sorting by the given field, returning -1, 0, or 1 if the first 
job is earlier, equal to, or later than the second job.

$anno destroy Release all resources associated with this anno instance and remove the 
command for controlling it from the interpreter.

$anno duration Retrieve the length of the build described in the anno object. This is the greatest 
time index seen in the annotation file.

$anno environment Dump the contents of the environment table, which was built out of the section 
of the annotation file. The result is a list of name/value pairs similar to [array 
get]. The list is unordered.

$anno file command filename Query the anno object for information about a file referenced by the build.

$anno file isdirectory filename Return a boolean indicating whether the specified file is a directory or not.

$anno file operations filename Return a Tcl list of lists describing the operations that referenced this file in the 
build.

$anno file type filename Return the file type for the specified file.

$anno files Retrieve a list of the files referenced in Operations in this annotation file.

$anno filecount Retrieve a count of the number of files referenced in Operations in this 
annotation file.

$anno indexagents For each agent in the annotation, construct a list of jobs run on that agent, sorted 
in order of time they were invoked. This index is stored internally, for use by 
ElectricInsight when rendering the annotation.

$anno load channel ?count? Parse count bytes of data from channel, creating job objects as necessary. 
The return value is a boolean indicating whether or not parsing is complete. If 
count is not specified then all data will be read from channel.
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$anno loadstring data ?done? Parse the data in data, creating job objects as necessary. There is no return 
value. If done is specified, it indicates whether or not the string represents the 
end of the XML data.

$anno job command jobId Invoke commands on a particular job from the annotation.

$anno job agent jobId Retrieve the name of the agent the job was run on.

$anno job annolength jobId Retrieve the length of the segment of the annotation file describing this job.

$anno job annostart jobId Retrieve the start of the segment of the annotation file describing this job.

$anno job commands jobId Retrieve a list of the commands associated with this job. The result is a list of 
lists with the form:
cmdlist = {[cmd]}
cmdlist is a list containing one or more cmd
cmd = {lines argv [output]}
cmd is a list containing lines, argv, and one or more output
lines = the actual line(s) from the makefile from where the command was 
issued, e.g. "11-12"
argv = the actual command issued to the system
output = {src out}
output is a list containing src and out
src = the source of the output, e.g. "make"
out = the actual string emitted by the component

$anno job conflict jobId Returns registry conflict information for the specified job.

$anno job conflictfile jobId If this job is a conflict job, retrieve the name of the file that it conflicted over.

$anno job conflicttype jobId If this job is a conflict job, retrieve the type of the conflict.

$anno job deps jobId Retrieve the list of history dependencies for this job. This may be empty if 
annotation did not include history-level detail, or if there were no history 
dependencies.

$anno job environment jobId Retrieve environment for the specified job.

$anno job exitcode jobId Retrieve the exit code for this job.

$anno job finish jobId Retrieve the end time of the job in seconds.

$anno job flags jobId Retrieve the flags for the job as a Tcl list.

$anno job isconflict jobId Returns a boolean indicating whether or not this job is a conflict job.

$anno job isrerun jobId Returns a boolean indicating whether or not this job is a rerun job.

$anno job isreverted jobId Returns a boolean indicating whether or not this job is a reverted job.

$anno job length jobId Retrieve the duration of the job in seconds. This is equivalent to
[$anno job jobId finish] - [$anno job jobId start], but 
it avoids using Tcl's [expr] command, so it is much faster. 

$anno job make jobId Retrieve the Make instance ID for the Make containing the specified job.

$anno job makefile jobId Retrieve the name of the makefile containing the rule that produced
this job, if any.

$anno job name jobId Retrieve the name for the specified job.

$anno job neededby jobId Retrieve the ID of the job that caused this job to be run.

$anno job operations jobId Retrieve the list of Operations performed by this job, in order, as a Tcl list of 
lists.
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$anno job operations -type registry 
jobId

Retrieve the list of registry operations for the specified job.

$anno job partof jobId Retrieve the ID of the job that this job continues. Only valid forcontinuation 
jobs; other jobs will return an empty string.

$anno job rerunjob jobId For conflict jobs, retrieve the job that was used to rerun the job.

$anno job serialorder jobId Retrieve the serial order of the job relative to the other jobs in the build; the first 
job in the build has serial order 1; the final job in the build has serial order N for 
a build with N jobs.

$anno job start jobId Retrieve the start time of the job in seconds.

$anno job timing jobId Retrieve the full timing information for this job as a list of lists of the form 
{start finish agent} {start finish agent} .... Normally 
there will be only one entry in the list; if the job was restarted due to
cluster sharing or agent failure, there will be additional entries. Jobs that never 
ran will return an empty list.

$anno job type jobId Retrieve the type of the specified job.

$anno job submakes jobId Retrieve the list of submakes performed by the specified job.

$anno job waitingjobs jobId Retrieve the list of jobs that had to wait for the job to complete before running. 
This may be empty if there are no waiting jobs, or if the annotation file did not 
include waitingJobs annotation.

$anno job writejob jobId For conflict jobs, retrieve the job that wrote the file that the job conflicted over.

$anno jobcount Return a count of the number of jobs in the annotation.

$anno jobiterbegin Initialize the job iterator to the head of the list of jobs in the anno object.

$anno jobitermore Return a boolean indicating whether the next call to 
[$anno jobiternext] will return a valid job or not. This is used in 
conjunction with [anno jobiterbegin] and [anno jobiternext] 
to efficiently iterate through the list of jobs in the anno object, in serial order.

$anno jobiternext Retrieve the job with the next highest serial order in the anno object using an 
iterator initialized with [anno jobiterbegin]. If the iterator has reached 
the end of the list of jobs, an empty string is returned; otherwise the job ID for 
the next job is returned, and the interator is advanced one step.

$anno jobsearch attribute pattern Search the jobs in the annotation for jobs that match the given criteria.

$anno make command makeId Invoke commands on a particular Make from the annotation.

$anno make commandline makeId Retrieve the command line for the specified Make.

$anno make job makeId Retrieve the job ID for the job that spawned the given Make instance, or an 
empty string if no job spawned the Make.

$anno make level makeId Retrieve the level of the specified Make instance.

$anno make mode makeId Retrieve the emulation mode of the given Make instance.

$anno make workingdir makeId Retrieve the working directory for the specified Make instance.

$anno makecount Return a count of the number of Makes in the annotation.

$anno metrics Dump the contents of the metrics table, which was built out of the section of the 
annotation file. The result is a list of name/value pairs similar to [array get]. The 
list is unordered.

$anno parseoptions ?optionList? Query or set the anno object parse options. This controls which portions of the 
annotation file are processed when [anno load] is invoked.
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$anno properties Dump the contents of the properties table, which was built out of the section of 
the annotation file. The result is a list of name/value pairs similar to [array get]. 
The list is unordered.

$anno refcount For testing only. Retrieve the reference count from the anno object.

$anno rjobiterbegin Initialize the job iterator to the end of the list of jobs in the anno object.

$anno rjobitermore Return a boolean indicating whether the next call to 
[anno rjobiternext] will return a valid job or not. This is used in 
conjunction with [anno rjobiterbegin] and 
[anno rjobiternext] to efficiently iterate through the list of jobs in the 
anno object, in reverse serial order.

$anno rjobiternext Retrieve the job with the next lowest serial order in the anno object using an 
iterator initialized with [anno rjobiterbegin]. If the iterator has reached 
the end of the list of jobs, an empty string is returned; otherwise the job ID for 
the next job is returned, and the iterator is advanced one step.

$anno sortjobs ?options? jobList Sort the jobs in jobList according to the given criteria. 
WARNING: This modifies the list IN PLACE.

$anno type command type Query aggregate attributes of jobs by type.

$anno type conflicttime type Returns the amount of time spent on jobs of this type that were later determined 
to be in conflict.

$anno type jobcount type Returns the number of jobs of this type.

$anno type reruntime type Returns the amount of time spent on jobs of this type that were rerun jobs.

$anno type revertedtime type Returns the amount of time spent on jobs of this type that were later reverted.

$anno type time type Returns the amount of time spent on jobs of this type that were not conflict, 
reverted, or rerun jobs.

$anno types Retrieve a list of known types of jobs.
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