
ElectricInsight 4.0
User's Guide

Electric Cloud, Inc.
35 South Market Street, Suite 100

San Jose, CA 95113
www.electric-cloud.com



ElectricInsight 4.0

Copyright © 2002–2014 Electric Cloud, Inc. All rights reserved.

Published 9/22/2014

Electric Cloud® believes the information in this publication is accurate as of its publication date. The information
is subject to change without notice and does not represent a commitment from the vendor.

THE INFORMATION IN THIS PUBLICATION IS PROVIDED “AS IS.” ELECTRIC CLOUD, INCORPORATED
MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND WITH RESPECT TO THE INFORMATION
IN THIS PUBLICATION, AND SPECIFICALLY DISCLAIMS IMPLIED WARRANTIES OF MERCHANTABILITY OR
FITNESS FOR A PARTICULAR PURPOSE.

Use, copying, and distribution of any ELECTRIC CLOUD software described in this publication requires an
applicable software license.

Copyright protection includes all forms and matters of copyrightable material and information now allowed by
statutory or judicial law or hereinafter granted, including without limitation, material generated from software
programs displayed on the screen such as icons, screen display appearance, and so on.

The software and/or databases described in this document are furnished under a license agreement or
nondisclosure agreement. The software and/or databases may be used or copied only in accordance with terms
of the agreement. It is against the law to copy the software on any medium except as specifically allowed in the
license or nondisclosure agreement.

Trademarks

Electric Cloud, ElectricAccelerator, ElectricCommander, ElectricInsight, and Electric Make are registered
trademarks or trademarks of Electric Cloud, Incorporated.

Electric Cloud products—ElectricAccelerator, ElectricCommander, ElectricInsight, and Electric Make—are
commonly referred to by their “short names”—Accelerator, Commander, Insight, and eMake—throughout
various types of Electric Cloud product-specific documentation.

Other product names mentioned in this guide may be trademarks or registered trademarks of their respective
owners and are hereby acknowledged.



Chapter 1: ElectricInsight Introduction 1-1
About ElectricInsight 1-1

Chapter 2: Installing ElectricInsight 2-1
Install Using the GUI 2-1
Install Using the Console 2-2

Installation Options 2-2

Chapter 3: Getting Started 3-1
Annotation 3-2
Starting ElectricInsight 3-2
Navigating the Interface 3-3

Agents & Jobs 3-3
Navigation 3-5
Overview 3-5
Legend 3-6
Job Summary 3-6
Zoom 3-7
Replay 3-7
Monitor Live Build 3-8

Chapter 4: Build, Job, and Make Information 4-1
Build Properties 4-2
Job Details Dialog 4-2

Job Details 4-3
Job Path 4-3
Annotation 4-4
Environment 4-5
Submakes 4-5

Make Details Dialog 4-6
Make Details 4-6
Make Jobs 4-7
Make Path 4-8

Searching for Jobs 4-8
Search Examples 4-9
Supported Search Fields 4-10

Viewing All Jobs 4-11
Using the Hyperlog 4-12

Chapter 5: Reports 5-1
Build Manifest 5-2

i

Contents



Build Metrics 5-2
Build Summary 5-3
Cluster Sharing 5-3
Derived Files Analysis 5-4
ElectricSimulator 5-5
Export Timeline 5-7
Files Modified Multiple Times 5-7
Job Stats 5-8
Job Time by Type 5-9
Jobs by Agent 5-10
Jobs by File 5-11
Longest Jobs 5-11
Longest Serial Chain 5-12
Makefile Manifest 5-13
Most Read Files 5-14
Root Conflicts 5-15
Serialization Analysis 5-15
Command-Line Enabled Reports 5-16
Creating a Custom Report 5-18

Chapter 6: Understanding Build Performance 6-1

Appendix A: Annolib Programmer's Reference A-1

ii



1-1

Chapter 1: ElectricInsight Introduction

Until now, there has been little visibility into builds to “see” why a build was slow, why a build broke, or which
dependencies were involved. ElectricInsight® (Insight) removes the “black box” around software product builds
and provides easy-to-understand performance data.

About ElectricInsight
Insight depicts how a build is structured and run, empowering build managers to pinpoint performance
problems or conflicts in a parallel build. Developed to work with ElectricAccelerator®, Insight mines information
produced by Electric Make® to provide an easy-to-understand, graphical representation of the build structure
for performance analysis.

Insight provides detailed information and reports for at-a-glance diagnostics for each job on each host in the
build cluster. Users can identify which jobs are performing, when, and with which files. Instead of manually
reading through tens of thousands of lines of information in log files, error detection and performance tuning that
used to consume hours or days can now occur in a few minutes or seconds.

By observing and tracing serialization sources or slowdowns, you can fine tune your build for maximum speed.
Insight gives you the ability to pinpoint areas to improve in your build process—and you will have answers for
these questions:

l Are any unnecessary serializations occurring?

l Is there a gap where one or more agents is not busy?

l Which job chains are the longest and can they be shortened?

l Which files are being modified (created, updated, or deleted) multiple times?
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Chapter 2: Installing ElectricInsight

Because Insight analyzes build annotation files, it is simplest to install it on the machine where you run Electric
Make, or on a Cluster Manager host where you can upload build annotation files.

The Insight distribution consists of the following files (Windows/Linux):

l einsight.exe/einsight - the ElectricInsight program

l annolib.dll/annolib.so - the annolib library

Install Using the GUI
To install Insight on Windows or Linux using the GUI, follow this procedure:

1. Run the appropriate install file to begin installation:

For Windows: ElectricInsight-<version>-Windows-Install.exe
You must run the installer as administrator. For example, on Windows systems running Windows 2008
or later, right-click the installer and select Run as administrator.

For Linux: ElectricInsight-<version>-Linux-x86-Install

2. Click Next on the Welcome screen.

3. Accept the default installation location:

o Windows - C:\ECloud\i686_win32\bin

o Linux - /opt/ecloud/i686_Linux/bin

Or click Browse to select a different location, and then click Next.

4. Click Browse to locate your license file, and click Next to continue.

If you choose to provide the license file later, ensure you name it license.xml and copy it to the
appropriate location in the Insight installation directory:

o For Windows: C:\ECloud\i686_win32\bin

o For Linux: /opt/ecloud/i686_Linux/bin

5. If the installer does not detect a PDF viewer, you are reminded to obtain one. Click Next.

6. Review your settings before continuing the installation. Click Next to continue or Back to make
changes.

Your installation is complete.
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7. Click Finish to close the installer.

Note: The Windows installation log is located in the following hidden directory: C:\Program
Files\InstallJammer Registry\

Install Using the Console
To install Insight on Linux using the console, follow this procedure (assumes you do not use any installation
options):

1. Run the install file: ElectricInsight-<version>-Linux-x86-Install

2. Accept the default install location, /opt/ecloud/, or designate a different location.

3. Type the location of your license file.

4. If the installer does not detect a PDF viewer, you are reminded to obtain one.

5. Press Enter to continue the installation.

Your installation is complete.

Installation Options
If you wish to launch the installer with options, use this format:

<installer filename> [options]

You can use multiple options to run an installation with customized settings and minimal interaction. The
following installation example runs in silent mode, designates the license file location, and sets a different
directory prefix:

ElectricInsight-4.0.0.0-Windows-Install.exe /mode silent /licensefile C:\mylicenses
/prefix C:\ecloud2

The following options are available to customize your installation:

Option Description

console Run the installation in the console (not the GUI).

help Display help information.

licensefile Set the license file that the installer imports. Type the full path to the license file. Example:
ElectricInsight-4.0.0.0-Windows-Install.exe /licensefile
C:\mylicenses

mode Set the installation mode. The following modes are available:

l standard - the standard installation mode, which includes all user prompts

l silent - runs the installation without user prompts

l default - runs the installation while accepting all installation defaults, resulting in
fewer user prompts

prefix Set the installation directory. Type the full path. Example:
ElectricInsight-4.0.0.0-Windows-Install.exe /prefix C:\ecloud2

temp Set the temporary directory used by the program.
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Option Description

version Display installer version information.
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Chapter 3: Getting Started

The following sections discuss what you need to know to start using Insight.

Topics:

l Annotation

l Starting ElectricInsight

l Navigating the Interface
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Annotation
ElectricInsight gathers information from build annotation files to create a picture of your build. To use Insight,
you must first run your builds with the --emake-annodetail parameter.

For example, on the eMake command line, run:

% emake ... --emake-annodetail=file,waiting,history ...

Note: Collecting annotation information may cause your build to run approximately 5% slower.

Supported Annotation Detail Levels

basic Detailed information about each “job” in the build, including command arguments, output,
exit code, timing, and source location

env Environment variable modification information

file Filesystem operations information, excluding lookups

history Information about implicit dependencies discovered by Electric Make

lookup Filesystem operations information, including lookups

md5 MD5 checksums for files read and written by the build

registry Registry operations information

waiting Information required to reconstruct the complete dependency graph

Note: The “Annotation” chapter in the Electric Cloud Electric Make Users Guide contains additional information
about annotation.

Annotation File Splitting
Because of limitations in ElectricInsight (a 32-bit application), eMake automatically partitions annotation files
into 1.6 GB “chunks.” The first chunk is named using the file name that you specify with the --emake-annofile
option or with “emake.xml,” if --emake-annofile is not specified. The second chunk uses that name as the
base but adds the suffix _1, the third chunk adds the suffix _2, and so on. For example, a four-part annotation
file might consist of files named emake.xml, emake.xml_1, emake.xml_2, and emake.xml_3.

No special action is required to load a multipart annotation file into ElectricInsight. If all parts are present in the
same directory, ElectricInsight automatically finds and loads the content of each file—simply specify the name of
the first chunk when opening the file in ElectricInsight.

Starting ElectricInsight
To start ElectricInsight:

1. Go to Start > All Programs > Electric Cloud > ElectricInsight

or

Type einsight at the command prompt. Optionally, you can specify the target annotation file.

% einsight [build-annotation-file]
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2. If you did not specify a build annotation file on the command line, click the folder icon on the toolbar or
select File > Load annotation.

3. Navigate to the annotation file of a completed build that you want to analyze and click Open.

Your build is now displayed.

Navigating the Interface
This section will familiarize you with the various portions of Insight's navigation.

Topics:

l Agents & Jobs

l Navigation

l Overview

l Legend

l Job Summary

l Zoom

l Replay

l Monitor Live Build

Agents & Jobs
In the Agents & Jobs section (outlined in the following screenshot), each agent used in the build is represented
by one row. Host names and agent number designations appear to the left of the agent job bars. Use the view
frame and arrows in the Navigation section to view agents that are not currently visible.
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The section’s x-axis is time, with the build starting at the left. The first job completed by each agent is at the
extreme left of an agent’s job bar. As you scroll to the right on an agent’s job bar, you see the progress of jobs
assigned to the agent.

The time grid helps you determine how long jobs take. The grid has major and minor grid lines. By default,
major grid lines are 60 seconds (pixels) apart and minor grid lines are 15 seconds (pixels) apart. Build
magnification is measured in pixels per second (pps). As you zoom in or out, this ratio increases or decreases.
Magnification is displayed in the lower right corner.

To see how long some jobs took to complete, click and drag from the left edge of the first job to the end of the
last job of interest. The job ruler appears and displays a time measurement. You can also use the ruler by
dragging from right to left.

Dependencies and Waiting Jobs Popup
You can right-click a job and select Show dependencies or Show waiting jobs. Dependencies are outlined in
blue. Waiting jobs (not present in the screenshot) are outlined in red.
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For dependency details between a pair of jobs, load an annotation file that contains waiting and history level
annotation and run the Serialization Analysis report.

Navigation
In the Navigation section, the view frame indicates which part of the build the Agents & Jobs section currently
displays. If the entire build is displayed, the view frame is the same size as the scroll bar. Drag the frame to view
different build stages. You can also use the arrows on either side of the navigation bar to move the view frame.

Below the Navigation section is a field showing how long it took Insight to load build annotation information.

Overview
The Overview section displays the following build information:

l Build ID and whether it was successful

l Build duration

l Number of makes in the build

l Number of agents and hosts used by the build

l Number of jobs in the build

l Annotation details collected in the build



ElectricInsight

3-6

Keep in mind the following terminology:

l Each makefile has one or more rules (lines of text).

l A target is the rule output.

l A command is a single shell invocation in a rule.

l A job corresponds to a rule scheduled as part of a build—in most cases.

l There are jobs that parse a makefile. Jobs also have status—possible status values include normal,
conflict, rerun, reverted, and skipped. For more details about job status, see Supported Search Fields.

Note: You can hide the Overview, Legend, and Job Summary sections, by clicking the gray bar between those
sections and the Agents & Jobs section. Click it again to show the hidden sections.

Legend
The Legend section displays the total number of jobs for each type and status within the build. Click a job type
or status to list all of its instances within the build. Legend colors correspond to the job type and status for
individual jobs within agent job bars.

The Agents & Jobs section displays two dimensions of job data—job status and job type. If the job status is not
unusual, then only the job type (such as parse or rule) is displayed. If a job has an unusual status (such as
conflict or reverted), that color is used for the lower portion of the job and the upper portion retains the color of
the job type.

Job Summary
To display a job’s summary information, mouse over any job in an agent job bar. The selected job is outlined in
pink in the agent job bar.

The Job Summary section displays the following information about the selected job:

l Job ID and job type or status (for additional information about job types and status, see Supported
Search Fields)

l Start time (as an offset from the build start time)

l End time

l Job length in hours/minutes/seconds

l Output target name, if applicable
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Zoom
The Tools menu contains the following magnification options:

l Zoom in and Zoom out - You can also zoom in or out using the magnifying glass icons in the toolbar or
by pressing CTRL-[equal sign] or CTRL-[minus sign].

l Zoom to... - This option allows you to specify a magnification factor for the display. To return to the initial,
unzoomed view, select Tools > Zoom to... and type a zoom factor of 1.0.

l Zoom to fit - This option sizes the display to fit the available space. Doing this may leave empty space to
the left of all agent job bars, which depicts the time when eMake was parsing the makefile, before agents
were assigned jobs. It is also possible that agents you are not currently viewing were working while
agents you are viewing were not assigned to this build.

Replay
Insight enables you to replay your build in the Agents & Jobs section so you can observe its progress.

You can display the replay toolbar by clicking Replay > Show.

The following screenshot shows the replay toolbar and a build replay in progress.
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Replay controls:

l Play - starts the replay.

l Fast forward - increases replay speed. You can click fast forward up to three times to speed up the
replay. Clicking a fourth time returns the speed to normal.

l Pause - pauses the replay. Click play to start again.

l Stop - stops the replay.

Monitor Live Build
Insight enables you to monitor a live build in the Agents & Jobs section. Follow these steps:

1. Select File > Monitor live build to display the following dialog.

2. Provide the host and port information from the --emake-monitor command-line option:

o Host is the hostname/IP of the Insight machine where the build will be monitored.

o Port is the port number of the Insight machine that listens for the data.

3. Click OK.

4. Make sure --emake-monitor=<hostname/IP>:<port> is added to the command line.

5. Start the build.
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Note: To monitor a live build, you must launch the Insight live build monitor before you start the build.
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Chapter 4: Build, Job, and Make Information

This section discusses how to view detailed build, job, and make information.

Topics:

l Build Properties

l Job Details Dialog

l Make Details Dialog

l Searching for Jobs

l Viewing All Jobs

l Using the Hyperlog
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Build Properties
To view overall build properties, click File > Build Properties. Three tabs are available: Properties, Environment,
and Performance Metrics.

The Environment tab displays build environment information, which you can copy to the clipboard:

1. Right-click anywhere in the window.

2. Select Copy to clipboard.

3. Select ...for bash/ksh or ...for cmd.

Job Details Dialog
To open the Job Details dialog, double-click a job in the Agents & Jobs section. Three tabs are always
available: Job Details, Job Path, and Annotation. The Submakes tab is available if the job includes submakes.
The Environment tab is available if you specified the env annotation level.

Topics:

l Job Details

l Job Path

l Annotation

l Environment

l Submakes
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Job Details
This tab displays summary information about the job. The following fields contain the same information as they
do on the main screen: ID, Type, Start, End, and Length.

For some job types, the Target name,Makefile, and Output fields are populated.

If the Output field is populated, you can enable Show commands to see the makefile line(s) that correspond to
the job.

The Makefile field identifies the makefile and the relevant line in that makefile that created the job. You can click
the makefile to open it in an editor. The Makefile field is empty for parse-type jobs because parse jobs are not
created from a line in a makefile. For example, there is no rule in the makefile that instructs eMake to parse the
makefile. To find which makefile a job parses, refer to the Directory and Name columns in the Job Path tab.

You can search the Output field by pressing CTRL-F. Pressing CTRL-G finds the next occurrence.

Job Path
This tab displays the path to the makefile line(s) that created the job.

The first line contains the command that invokes the top level makefile. Typically, this line invokes another
makefile. If it does, the second line displays the job ID. If it does not invoke another makefile, the second line
displays the name of the target the job executes.
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If the makefile line that created the job invoked a second makefile, this pattern of makefile lines and job IDs is
repeated, chaining through makefiles until the target that created the job is reached.

Annotation
This tab displays the portion of the annotation file pertaining to the job.

Pressing CTRL-F searches for and highlight text; CTRL-G finds the next occurrence.
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Environment
This tab displays environment information that was used to run the job. The Environment tab is available only if your
annotation file includes env level annotation.

You can copy environment information to the clipboard:

1. Right-click anywhere in the window.

2. Select Copy to clipboard.

3. Select ...for bash/ksh or ...for cmd.

Submakes
This tab lists all submakes that the job runs, including their ID, Directory, and Command line make command.
The Submakes tab is available only if the job includes submakes.

Double-click an entry in the list to display the job’s detail dialog.
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Make Details Dialog
To open the Make Details dialog, double-click a make command, for example, in the Job Path tab of the Job
Details dialog. Three tabs are available: Make Details, Make Jobs, and Make Path.

Topics:

l Make Details

l Make Jobs

l Make Path

Make Details
This tab displays information about make. The tab has the following fields: ID, Level, Emulation mode, Directory,
and Command line.
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Make Jobs
This tab lists all jobs that the makefile runs.
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Make Path
This tab displays the path to the makefile line(s) that created the make.

The first line contains the command that invokes the top level makefile. Typically, this line invokes another
makefile. If it does, the second line displays the job ID. If it does not invoke another makefile, the second line
displays the name of the target the job executes.

Searching for Jobs
If you know the job ID you want to find:

1. Go to Tools > Find job by ID to go to job details.

2. Enter the Job ID.

3. Click OK.

If you do not know the job ID, you can search for jobs using several criteria. Follow these steps:

1. Go to Tools > Search jobs.
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2. Type-in the strings you want to find (example, “gcc conflict”). You can also constrain your search by
searching for specific values in specific fields. See Search ExamplesSupported Search Fields.

3. Click Search.

The values come from fields in the build annotation file.

4. You can sort your results by selecting an option from the drop-down.

5. Double-click a row to display a job’s Job Details dialog.

6. In the dialog’s lower-right corner, click Go to job.

The job is now highlighted in the Agents & Jobs section.

Search Examples
Finds rule jobs involved in conflicts:

rule conflict or type:rule status:conflict

Finds conflicts involving jobs named “export”:
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conflict name:export

Finds rerun jobs with names including “port”:

rerun name:*port*

Finds non-reverted jobs with names ending in “Makefile”:

!reverted name:*Makefile

Supported Search Fields
The following fields are supported:

l name - the name of a job is the name of the target that created it. Continuation and parser jobs do not
have names.

l commands - search makefile command lines and output. Globbing patterns are supported (for example,
commands:gcc *foo*).

l status - possible values include:

o normal - a successfully run job

o conflict - a job involved in a conflict. Many of these jobs or jobs on which they rely are reverted.
Typically, conflicts occur when there is no history file—when the environment does not provide
Electric Make with enough information to predict all job dependencies.

o rerun - some reverted jobs must be run with correct file system context. Rerun jobs are always
serialized to guarantee correct context.

o reverted - a job is reverted when Electric Make serializes job results and the job in question was
executed before a (logically) preceding job that failed. The preceding job may have failed because
of a conflict. Reverting a job restores the Agent’s file system to the state before the job was run.

o skipped - skipped jobs are the same as reverted jobs except the skipped job did not run before the
preceding job failed.

l type: possible values include:

o continuation - a continuation job occurs when commands associated with a makefile target include a
submake (also known as, recursive make). Typically, these submake commands begin with
$(MAKE). The commands below a submake, down to and including the next submake command (for
the same target), comprise a continuation job. For a target, there are as many continuation jobs as
there are submakes with commands after them.

all:
echo abc
$(MAKE) abc
echo def
echo ghi
$(MAKE) ghi
echo jkl
$(MAKE) jkl

In this example, the first continuation job starts with echo def and ends with $(MAKE) ghi. The
second and last continuation job consists of two commands involving jkl.

o end - clean-up tasks that occur at the end of makefiles (for example, removing intermediate files).

o exist - jobs corresponding to top-level targets without rules. Electric Make verifies the target exists.
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o follow - one of these jobs follows every submake to handle submake output and exit status for the
parent.

o parse - jobs that parse makefiles.

o remake - jobs that remake makefiles (only for GNU make).

o rule - lists jobs corresponding to makefile rules. Sorting results by name allows you to find the job
that executed a specific rule. If you have several rules (in different makefiles) with the same name,
you can display several Job Details dialogs at once.

l make - this is the ID of the makefile that created the job. The top-level makefile has ID 0 (zero). For
example, make:0 returns a list of jobs created directly from the top-level makefile.

l job - the job ID, for example, job:J01b11200

l neededby - the job in question is needed by another job. Specify the job ID of the job that needs the job
in question, for example, neededby:J01b11200. This is useful for tracking inter-job dependencies.

l length - job length, in seconds. If you specify length:12.34, you find jobs that lasted exactly 12.34
seconds only. You can also search using length:>12.34, length:>=12.34, length:==12.34,
length:<12.34, and length:<=12.34. To find jobs that lasted 10-15 seconds, specify
length:>=10.0 length:<=15.0.

l exitcode - the job exit code. To find jobs with a non-zero exit code use exitcode:!=0. In general, use
arithmetic relations (=, >, <, >=, <=) to search numerical values and use no relation symbols when
searching for string values.

l waitingJobs:<jobID> - to find prerequisite jobs of <jobID>.

l start - job start time (in seconds) after the build start time. To find other jobs that started in the first minute
of the job, use start:<60. To find jobs that took more than 60 seconds and started during the 10th
minute into the build, type length:>60 start:>=600 start:<660.

l finish - the job end time (in seconds) after the build start time.

l restarts - lists jobs restarted a specified number of times. Jobs are restarted because of cluster sharing
and agent failure.

Note: You can restrict the search scope for the following fields only: type, status, name, make, and job.

Viewing All Jobs
If you want to list all of the build’s jobs, go to Tools > View all jobs...
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Using the Hyperlog
The hyperlog presents an augmented version of the familiar build output log, leveraging the extra information
provided by Electric Make to enable highlighting errors and warnings, folding of submake output, and line
numbering.

To access the hyperlog, click the Go to log button on any Job Details dialog. When the hyperlog opens, you go
directly to the corresponding job's location. You can also go to Tools > View build log... to access the hyperlog.

Double-clicking any line of log output displays the corresponding job's details dialog.

Note: The hyperlog is not available when monitoring a live build because the log file doesn't exist.
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Chapter 5: Reports

You can generate reports from the GUI and the command-line.

In the GUI, to display the Reports dialog, select Tools > Reports or click the reports icon on the toolbar. You can
open one report at a time for each Insight instance, but you can open several Insight instances. You can run
most reports by double-clicking the report name. Some reports have mandatory parameters that you must
provide before running them.

Some reports listed here can be generated through both methods, and some reports can be generated through
one method only.

With ElectricInsight's command-line reporting capability, the product can be integrated to generate batch trend
reports as part of a build automation system. For a list of all command-line enabled reports and their associated
commands, see Command-Line Enabled Reports.

Topics:

l Build Manifest

l Build Metrics

l Build Summary

l Cluster Sharing

l Derived Files Analysis

l ElectricSimulator

l Export Timeline

l Files Modified Multiple Times

l Job Stats

l Job Time by Type

l Jobs by Agent

l Jobs by File

l Longest Jobs

l Longest Serial Chain

l Makefile Manifest

l Most Read Files

l Root Conflicts

l Serialization Analysis

l Creating a Custom Report
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Build Manifest
The Build Manifest report lists all files that were read and/or written by the build.

This report can help to:

l Verify that all files read by the build are the latest version from source control

l Add all files written by the build to an archive

l Produce a list of all inputs and a list of all outputs

l Identify files that are written but never read

This report requires

--emake-annodetail=basic,file

To export the report to a .csv file, click Export.

To run a shell command:

1. Click Run Command.

2. Type a command and a pathname in the Run Shell Command dialog.

The shell command is run with each file in the filtered list as an argument. Results and errors are
displayed under their corresponding tabs.

Build Metrics
This command-line-only report prints the content of the <metrics> element in the annotation.
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Run:

einsight --report=BuildMetrics <annotation>

Note: On Windows, use einsight-cmd instead of einsight when running reports from the command-line.

Where <annotation> is the path and name of the annotation file.

Results format:

name,value

Build Summary
This command-line-only report prints the information from the left-side of the main Insight display.

Run:

einsight --report=BuildSummary <annotation>

Note: On Windows, use einsight-cmd instead of einsight when running reports from the command-line.

Where <annotation> is the path and name of the annotation file.

Results format:

name,value

Cluster Sharing
The Cluster Sharing report shows the total work time lost (sum of aborted job run-times) and net build time lost
(total work time minus overlaps) due to cluster sharing over the lifetime of the build.

This report is useful if your build aborts jobs because an agent host is de-allocated from the build. The host may
have been allocated to another build, moved to another cluster, or simply shut down. The aborted jobs must be
rerun, resulting in a slower build.

This report does not consider the effect of not using some agent hosts because other builds are using them. To
evaluate this factor, use the ElectricSimulator report.

Example

l Job A starts 5 seconds into the build.

l Job B starts 10 seconds into the build.

l Both jobs are terminated 20 seconds into the build.

The total work time lost is 15 + 10 seconds, but the net build time lost is only 15 seconds because the build time
lost by B overlaps the build time lost by A.
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Derived Files Analysis
The Derived Files Analysis report allows you to view a specified file’s affected outputs. For example, this report
answers the question, “If I change file X, what outputs will be affected?” A file is likely to be affected if it is
produced concurrently with, or subsequent to, reads of the specified file.

This report requires

--emake-annodetail=file,history
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To run the report:

1. Enter the file(s) with full paths in the input field.

2. Click Run.

The middle display area lists files that will change when the input file changes. Double-click a file in this list to
display its chain of operations in the lower display area.

Double-click an item in the lower display area to display its Job Details dialog.

To clear all fields, click Clear.

To copy the displayed chain of operations (in the lower display area) to the clipboard, click Copy Report.

ElectricSimulator
The ElectricSimulator report predicts build performance on a variety of cluster sizes. The last time indicator (blue
bar) is the best possible build time.

This report requires

--emake-annodetail=waiting



ElectricInsight

5-6

Note: The simulator time results are estimates only. They do not indicate guaranteed performance.

o Minimum agents - the minimum number of agents to simulate. Default is 4.

o Maximum agents - the maximum number of agents to simulate. Default is 32.

o Step size - the number of agents to increment the count each time. Default is 4.

Command-Line Interface Report
Run this command:

einsight --report="ElectricSimulator [minagents] [maxagents] [stepsize]" <annotatio
n>

Note: On Windows, use einsight-cmd instead of einsight when running reports from the command-line.

Where:

[minagents] (optional) is the minimum number of agents to simulate. Default is 4.

[maxagents] (optional) is the maximum number of agents to simulate. Default is 32.

[stepsize] (optional) is the number of agents to increment the count each time. Default is 4.
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<annotation> is the path and name of the annotation file.

Results format:

agents,duration

Export Timeline
This command-line-only report exports the main build timeline view to a graphic.

Run:

einsight --report=ExportTimeline <filename> [mode] [scale] [rowheight] [rowspace] <
annotation>

Note: On Windows, use einsight-cmd instead of einsight when running reports from the command-line.

Where:

o <filename> is the name of the PNG file to write to. (Required)

o [mode] indicates if you want the image in color or black and white. Valid values are color or bw.
Default is color. (Optional)

o [scale] is the number of seconds per pixel. Default is 2. (Optional)

o [rowheight] is the number of pixels per row of jobs. Default is 1. (Optional)

o [rowspace] is the number of pixels separating rows. Default is 1. (Optional)

o <annotation> is the path and name of the annotation file. (Required)

Files Modified Multiple Times
This report shows which files are modified (created, updated, or deleted) multiple times during a build.

Jobs involving these files require careful serialization to ensure the file operations sequence is performed in the
correct order.

This report requires

--emake-annodetail=file
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After you run the report, filter the results:

1. Type the string you want to filter for in the Filter field.

Use an asterisk to match any number of characters, and use a question mark to match any single
character.

You can also use simple regular expressions, for example, *[xz].o and *[x-z].o

Filters are case sensitive.

2. Press Enter.

Job Stats
This report groups jobs based on duration and shows the percentage of jobs in each group, as well as the
percentage of total build workload represented by the jobs in each group.
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Command-Line Interface Report
Run this command:

einsight --report=JobStats <annotation>

Note: On Windows, use einsight-cmd instead of einsight when running reports from the command-line.

Where <annotation> is the path and name of the annotation file.

You can also limit results to a job class, such as "compile" or "link". To limit your results, run this command:

einsight --report="JobStats <jobclass>" <annotation>

Where <jobclass> is the only job class you want to see, which can be link, compile, parse, etc.

Results format:

duration,count,time,count percent,time percent

Job Time by Type
This report shows the portion of total job time consumed by each job type. The area covered by each color is
proportional to the total time consumed by its corresponding job type.
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The legend displays corresponding colors for job types. The following information is available:

l Category

l Time (s)

l % of total

l # jobs

l Average (s)

Note: To sort data, click a column heading.

Clicking a row outlines the corresponding area in the treemap in yellow and lists all jobs of that type in the Jobs
section. Double-clicking a job from the list displays that job’s details. You can also display all jobs of a specific
type by clicking an area of the treemap.

Command-Line Interface Report
Run this command:

einsight --report=JobTimeByType <annotation>

Note: On Windows, use einsight-cmd instead of einsight when running reports from the command-line.

Where <annotation> is the path and name of the annotation file.

Results format:

class,count,percent,seconds,average

Jobs by Agent
This report lists the number of jobs run by each agent in the build.
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Click an agent to display the jobs that it ran. Double-click a job to display its details.

Jobs by File
This report lists which jobs read or wrote a particular file.

Type in or browse to the file you want to analyze and click Analyze.

Longest Jobs
This report lists the build’s 10 longest jobs.
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To view the Job Details dialog, double-click a job ID.

Command-Line Interface Report
Run this command:

einsight --report=LongestJobs <annotation>

Note: On Windows, use einsight-cmd instead of einsight when running reports from the command-line.

Where <annotation> is the path and name of the annotation file.

Results format:

job id,duration,name

Longest Serial Chain
This report displays the sequence of serialized jobs with the longest end-to-end runtime in the build. The
longest serial chain represents a lower bound on the build runtime. Without changing the structure or content of
the build, the runtime cannot be less than the longest serial chain.

This report requires

--emake-annodetail=waiting,history
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You can display the longest serial chain overall or the longest serial chain leading to a specific job.

To display the Job Details dialog, double-click a job.

Command-Line Interface Report
Run this command:

einsight --report="LongestSerialChain [job id]" <annotation>

Note: On Windows, use einsight-cmd instead of einsight when running reports from the command-line.

Where:

[job id] is a job ID (optional). Specifying a job ID means that you want to find the longest serial chain leading
to that job. If you don't specify a job ID, the report returns the longest serial chain overall.

<annotation> is the path and name of the annotation file.

Results format:

job,type,length,name

Makefile Manifest
This report lists all makefiles used in the build.
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To export the list to a file, click Export.

Most Read Files
This report lists the number of times a file was read, its name, type, and location.

Command-Line Interface Report
Run this command:

einsight --report=MostReadFiles <annotation>

Note: On Windows, use einsight-cmd instead of einsight when running reports from the command-line.

Where <annotation> is the path and name of the annotation file.

Results format:

count,type,name,location
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Root Conflicts
This report lists all root conflicts in the build.

Insight divides all conflicts found in a build into two categories:

l root conflicts, which are conflicts that are not caused by an earlier conflict

l conflicts resulting from earlier conflicts (for example, jobs that are in conflict with jobs that are rerun jobs)

Serialization Analysis
This report details dependencies between a pair of jobs. For example, you see in the Annotation tab that a job
has waitingJobs and you want to know why the jobs are waiting.

In some cases you can use this report to understand the longest serial chain, but dependencies may exist that
are not within the scope of the Serialization analysis report. For example, it is common for a rule job to be
preceded by a parse job. This type of logical dependency is not included in the Serialization analysis report.

This report requires

--emake-annodetail=waiting,history

but works best with

--emake-annodetail=waiting,history,registry
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1. Type the ID of the job you started first in the first job field.

2. Type the ID of the waiting job in the second job field.

3. Click Locate Dependency.

Note: If you know where the jobs [of interest] appear in the main jobs display, you can use the buttons next to
the job fields to select the jobs.

Command-Line Enabled Reports
This section lists all command-line enabled reports and their associated commands.

For all reports, <annotation> is required and represents the path and name of the annotation file.

IMPORTANT: For Windows, use einsight-cmd instead of einsight when running reports from the
command-line.

Build Metrics
einsight --report=BuildMetrics <annotation>

Results format:

name,value

Build Summary
einsight --report=BuildSummary <annotation>

Results format:

name,value
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ElectricSimulator
einsight --report="ElectricSimulator [minagents] [maxagents] [stepsize]" <annotatio
n>

Where:

[minagents] (optional) is the minimum number of agents to simulate. Default is 4.

[maxagents] (optional) is the maximum number of agents to simulate. Default is 32.

[stepsize] (optional) is the number of agents to increment the count each time. Default is 4.

Results format:

agents,duration

Export Timeline
einsight --report=ExportTimeline <filename> [mode] [scale] [rowheight] [rowspace] <
annotation>

Where:

o <filename> is the name of the PNG file to write to. (Required)

o [mode] indicates if you want the image in color or black and white. Valid values are color or bw.
Default is color. (Optional)

o [scale] is the number of seconds per pixel. Default is 2. (Optional)

o [rowheight] is the number of pixels per row of jobs. Default is 1. (Optional)

o [rowspace] is the number of pixels separating rows. Default is 1. (Optional)

Job Stats
einsight --report=JobStats <annotation>

You can also limit results to a job class, such as "compile" or "link". To limit your results, run this command:

einsight --report="JobStats <jobclass>" <annotation>

Where <jobclass> is the only job class you want to see, which can be link, compile, parse, etc.

Results format:

duration,count,time,count percent,time percent

Job Time by Type
einsight --report=JobTimeByType <annotation>

Results format:

class,count,percent,seconds,average

Longest Jobs
einsight --report=LongestJobs <annotation>

Results format:

job id,duration,name

Longest Serial Chain
einsight --report="LongestSerialChain [job id]" <annotation>
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Where [job id] is a job ID (optional). Specifying a job ID means that you want to find the longest serial chain
leading to that job. If you don't specify a job ID, the report returns the longest serial chain overall.

Results format:

job,type,length,name

Most Read Files
einsight --report=MostReadFiles <annotation>

Results format:

count,type,name,location

Creating a Custom Report
You can create custom reports and make them accessible in Insight.

A report typically consists of:

l a single .tcl source file containing Tcl code required to perform build annotation analysis

l the Tk code required to display the result in the Insight UI

An example custom report could be one that displays the number of jobs run by each agent used in the build.

Follow these steps to create a custom report:

1. Create a Tcl script that uses CreateReport and ConfigureReport to declare and set attributes for a report,
using this format:

CreateReport name ?-option value ...?

Valid options:

-command Command for generating a text-only version of the report

-guicommand Command for generating a GUI version of the report

-desc Description of the report

-requires Space-separated list of anno detail levels required for the report

-cleanup Command to invoke to clean up state associated with the report,
e.g., when a new anno file is loaded

You must specify at least one of -command and -guicommand.

For example:

set report [CreateReport "MyCustomReport"]
ConfigureReport $report -desc "The report description \
a continuation of the report description."
ConfigureReport $report -requires {basic file waiting history}
ConfigureReport $report -command RunCustomReport
ConfigureReport $report -uicommand MakeCustomReportUI

Notes:
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l Make sure the console version of the report returns the report results as a text string (i.e., don't
just print directly with [puts]).

l If you're running the Insight GUI and you invoke a custom report that has no -guicommand,
Insight will run the -command version, capture the output, and display it as raw text in the GUI.

2. Add to the Tcl script the function to perform the analysis and display results. The function is invoked with
two arguments:

o The name of the “widget” the function needs to create to display results.

o (The progressVar argument is optional.) The name of the variable the function needs to update
with progress information, from 0.0 to 1.0. This information controls the “progress bar” when the
report is generated.

proc CreateJobsByAgentReport {w progressVar} {

In addition to function arguments, a global variable anno is available for reports. This is a handle for the
annolib object containing build annotation information currently loaded in ElectricInsight. To access
this information in your report, import the anno variable: global anno

3. Add Tcl code to perform the analysis on the annotation information:

# Iterate through all the jobs in the build, counting
# the number of jobs run by each agent.

array set count {}
$anno jobiterbegin
while { [$anno jobitermore] } {

set job [$anno jobiternext]
set agent [$anno job agent $job]
if { $agent ne ““ } {

if { [info exists count($agent)] } {
incr count($agent)

} else {
set count($agent) 1

}
}

}

4. Write Tk code to display results.

Insight includes the [Tile] widgets and the [Tablelist] widget. For this report, a simple tablelist can
display the results:

# The “count” array contains the number of jobs run by
# each agent.
# We create a simple tablelist (multi-column listbox)
# to display the results.

frame $w
ttk::label $w.label -text “Jobs by agent:” -anchor w
tablelist::tablelist $w.results -columns {

0 “Agent”
0 “Jobs run by this agent”

} -height 10 -width 80 -borderwidth 1 -stretch end \
-font TkDefaultFont -background gray98 \
-stripebackground \#e0e8f0 \
-labelcommand tablelist::sortByColumn

$w.results columnconfigure 1 -sortmode integer
grid $w.label -sticky ew
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grid $w.results -sticky nsew
grid columnconfigure $w 0 -weight 1
grid rowconfigure $w 1 -weight 1

foreach agent [lsort [array names count]] {
$w.results insert end [list $agent $count($agent)]

}
return $w

}
# end of procedure CreateJobsByAgentReport

5. Save the .tcl files that define your new report in one of the following directories.

o On Linux:

l /opt/ecloud/ElectricInsight/reports

l $HOME/.ecloud/ElectricInsight/reports

o On Windows:

l c:\ecloud\ElectricInsight\reports

l $USERPROFILE\Electric Cloud\ElectricInsight\reports

On startup, Insight scans the directories listed above for .tcl files defining new reports and automatically
includes the reports the next time Insight starts. Reports saved in the Electric Cloud directories listed
above are available to all users running Insight. Reports in other locations are available to a single user
only.

6. Select Tools > Reload reports.
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Chapter 6: Understanding Build Performance

This section provides guidance for using Insight to help you understand build performance issues.

l Specify the right annotation detail level

At a minimum, specify annodetail to basic. Additional detail levels enable more sophisticated analysis of
the build. For maximum performance analysis, set annodetail to “basic,lookup,waiting,history,registry”.
Because additional information may affect performance slightly, specify basic detail level only, unless
you are actively pursuing a performance issue.

l Use job details

When viewing an annotation file in Insight, you can see if your build is slow due to excessive conflicts,
over serializations, or insufficient decomposition of build steps. You can then drill-down into job details
by double-clicking individual jobs in the Agents & Jobs section.

l Use reports

o The Longest serial chain report can help estimate the best possible performance you can
reasonably get from the build.

o The Serialization analysis report can help you understand why jobs are serialized. In an optimal
parallel build, all agents are busy at the same time.

For example, the image on the left shows a build that suffers from over serialization. Using the
Serialization analysis report, you can determine why the build is serialized and adjust the build to
eliminate serializations. The image on the right shows the result of making the correct adjustments.
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l Watch for the following in the Agents & Jobs section:

o One agent bar is longer than others

o If you see gaps where an agent is not running a job, carefully examine the running jobs while some
agents are idle

l Conflicts and reverted jobs

The presence of conflict and reverted jobs means the build was slower than necessary. Reverted jobs
are symptoms of job conflicts. To eliminate reversions, you must eliminate conflicts. Usually, running a
build with a history file eliminates conflicts. Typically, the most expensive job conflicts are those involving
parse jobs.

If your build ran without a history file, you may have conflicts. If you had a pre-existing history file, your
build should not contain conflicts unless the build changes affected job order and inter-dependencies.
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Appendix A: Annolib Programmer's Reference

annolib is the library used to parse annotation files. Required values are enclosed in < > (for example
<filename>). Optional values are enclosed in ? (for example ?count?).

l anno create - Create a new anno object that can be used to query information from an annotation file.
The return value is a handle which can be used in a subsequent [$anno ...] call. For example:

set anno [anno create]

$anno agents

l $anno agents - Retrieve a list of agents that participated in this build.

l $anno comparejobs <field> <jobId> <jobId> - Compare two jobs for sorting by the given field,
returning -1, 0, or 1 if the first job is earlier, equal to, or later than the second job.

l $anno destroy - Release all resources associated with this anno instance and remove the command
for controlling it from the interpreter.

l $anno duration - Retrieve the length of the build described in the anno object. This is the greatest
time index seen in the annotation file.

l $anno environment - Dump the contents of the environment table, which was built out of the section of
the annotation file. The result is a list of name/value pairs similar to [array get]. The list is unordered.

l $anno file <command> <filename> - Query the anno object for information about a file referenced
by the build.

l $anno file isdirectory <filename> - Return a boolean indicating whether the specified file is a
directory or not.

l $anno file operations <filename> - Return a Tcl list of lists describing the operations that
referenced this file in the build.

l $anno file type <filename> - Return the file type for the specified file.

l $anno files - Retrieve a list of the files referenced in Operations in this annotation file.

l $anno filecount - Retrieve a count of the number of files referenced in Operations in this annotation
file.

l $anno indexagents - For each agent in the annotation, construct a list of jobs run on that agent, sorted
in order of time they were invoked. This index is stored internally, for use by ElectricInsight when
rendering the annotation.
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l $anno load <channel> ?count? - Parse ?count? bytes of data from <channel>, creating job objects
as necessary. The return value is a boolean indicating whether or not parsing is complete. If ?count? is
not specified, all data will be read from <channel>.

l $anno loadstring <data> ?done? - Parse the data in <data>, creating job objects as necessary.
There is no return value. If ?done? is specified, it indicates whether or not the string represents the end
of the XML data.

l $anno jobcommand <jobId> - Invoke commands on a particular job from the annotation.

l $anno jobagent <jobId> - Retrieve the name of the agent the job was run on.

l $anno job annolength <jobId> - Retrieve the length of the segment of the annotation file
describing this job.

l $anno job annostart <jobId> - Retrieve the start of the segment of the annotation file describing
this job.

l $anno job commands <jobId> - Retrieve a list of the commands associated with this job. The result is
a list of lists with the form:

cmdlist = {[cmd]}
cmdlist is a list containing one or more cmd
cmd = {lines argv [output]}
cmd is a list containing lines, argv, and one or more output
lines = the actual line(s) from the makefile from where the command was issued, for example "11-12"
argv = the actual command issued to the system
output = {src out}
output is a list containing src and out
src = the source of the output, e.g. "make"
out = the actual string emitted by the component

l $anno job conflict <jobId> - Return registry conflict information for the specified job.

l $anno job conflictfile <jobId> - If this job is a conflict job, retrieve the name of the file that it
conflicted over.

l $anno job conflicttype <jobId> - If this job is a conflict job, retrieve the type of the conflict.

l $anno job deps <jobId> - Retrieve the list of history dependencies for this job. This may be empty if
annotation did not include history-level detail, or if there were no history dependencies.

l $anno job environment <jobId> - Retrieve environment for the specified job.

l $anno job exitcode <jobId> - Retrieve the exit code for this job.

l $anno job finish <jobId> - Retrieve the end time of the job in seconds.

l $anno job flags <jobId> - Retrieve the flags for the job as a Tcl list.

l $annojob isconflict <jobId> - Return a boolean indicating whether or not this job is a conflict job.

l $anno job isrerun <jobId> - Return a boolean indicating whether or not this job is a rerun job.

l $anno job isreverted <jobId> - Return a boolean indicating whether or not this job is a reverted
job.

l $anno job length <jobId> - Retrieve the duration of the job in seconds. This is equivalent to
[$anno job jobId finish] - [$anno job jobId start], but it avoids using Tcl's [expr]
command, so it is much faster.

l $anno job make <jobId> - Retrieve the Make instance ID for the Make containing the specified job.
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l $anno job makefile <jobId> - Retrieve the name of the makefile containing the rule that produced
this job, if any.

l $anno job name <jobId> - Retrieve the name for the specified job.

l $annojob neededby <jobId> - Retrieve the ID of the job that caused this job to be run.

l $anno job operations <jobId> - Retrieve the list of Operations performed by this job, in order, as a
Tcl list of lists.

l $anno job operations -type registry <jobId> - Retrieve the list of registry operations for the
specified job.

l $anno job partof <jobId> - Retrieve the ID of the job that this job continues. Only valid for
continuation jobs; other jobs will return an empty string.

l $anno job rerunjob <jobId> - For conflict jobs, retrieve the job that was used to rerun the job.

l $annojob serialorder <jobId> - Retrieve the serial order of the job relative to the other jobs in the
build; the first job in the build has serial order 1; the final job in the build has serial order N for a build
with N jobs.

l $anno job start <jobId> - Retrieve the start time of the job in seconds.

l $anno job timing <jobId> - Retrieve the full timing information for this job as a list of lists of the form
{start finish agent} {start finish agent} .... Normally there will be only one entry in the
list; if the job was restarted due to cluster sharing or agent failure, there will be additional entries. Jobs
that never ran will return an empty list.

l $anno job type <jobId> - Retrieve the type of the specified job.

l $anno job submakes <jobId> - Retrieve the list of submakes performed by the specified job.

l $anno job waitingjobs <jobId> - Retrieve the list of jobs that had to wait for the job to complete
before running. This may be empty if there are no waiting jobs, or if the annotation file did not include
waitingJobs annotation.

l $anno job writejob <jobId> - For conflict jobs, retrieve the job that wrote the file that the job
conflicted over.

l $anno jobcount - Return a count of the number of jobs in the annotation.

l $anno jobiterbegin - Initialize the job iterator to the head of the list of jobs in the anno object.

l $anno jobitermore - Return a boolean indicating whether the next call to [$anno jobiternext]
will return a valid job or not. This is used in conjunction with [anno jobiterbegin] and [anno
jobiternext] to efficiently iterate through the list of jobs in the anno object, in serial order.

l $anno jobiternext - Retrieve the job with the next highest serial order in the anno object using an
iterator initialized with [anno jobiterbegin]. If the iterator has reached the end of the list of jobs, an
empty string is returned; otherwise the job ID for the next job is returned, and the iterator is advanced
one step.

l $anno jobsearch <attribute pattern> - Search the jobs in the annotation for jobs that match the
given criteria.

l $anno make <command> <makeId> - Invoke commands on a particular Make from the annotation.

l $anno make commandline <makeId> - Retrieve the command line for the specified Make.

l $anno make job <makeId> - Retrieve the job ID for the job that spawned the given Make instance, or
an empty string if no job spawned the Make.
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l $anno make level <makeId> - Retrieve the level of the specified Make instance.

l $anno make mode <makeId> - Retrieve the emulation mode of the given Make instance.

l $anno make workingdir <makeId> - Retrieve the working directory for the specified Make instance.

l $anno makecount - Return a count of the number of Makes in the annotation.

l $anno metrics - Dump the contents of the metrics table, which was built out of the section of the
annotation file. The result is a list of name/value pairs similar to [array get]. The list is unordered.

l $anno parseoptions ?optionList? - Query or set the anno object parse options. This controls
which portions of the annotation file are processed when [anno load] is invoked.

l $anno properties - Dump the contents of the properties table, which was built out of the section of the
annotation file. The result is a list of name/value pairs similar to [array get]. The list is unordered.

l $anno refcount - For testing only. Retrieve the reference count from the anno object.

l $anno rjobiterbegin - Initialize the job iterator to the end of the list of jobs in the anno object.

l $ann orjobitermore - Return a boolean indicating whether the next call to [anno rjobiternext]
will return a valid job or not. This is used in conjunction with [anno rjobiterbegin] and [anno
rjobiternext] to efficiently iterate through the list of jobs in the anno object, in reverse serial order.

l $anno rjobiternext - Retrieve the job with the next lowest serial order in the anno object using an
iterator initialized with [anno rjobiterbegin]. If the iterator has reached the end of the list of jobs, an
empty string is returned; otherwise the job ID for the next job is returned, and the iterator is advanced
one step.

l $anno sortjobs ?options? <jobList> - Sort the jobs in <jobList> according to the given criteria.
WARNING: This modifies the list in place.

l $anno type <command> <type> - Query the aggregate attributes of jobs by type.

l $anno type conflicttime <type> - Return the amount of time spent on jobs of this type that were
later determined to be in conflict.

l $anno type jobcount <type> - Return the number of jobs of this type.

l $anno type reruntime <type> - Return the amount of time spent on jobs of this type that were rerun
jobs.

l $anno type revertedtime <type> - Return the amount of time spent on jobs of this type that were
later reverted.

l $anno type time <type> - Return the amount of time spent on jobs of this type that were not conflict,
reverted, or rerun jobs.

l $anno types - Retrieve a list of known types of jobs.
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