SMTP - User unknown

Article ID:115003819791
1 minute readKnowledge base

Issue

  • Unable to send emails - SMTPAddressFailedException

Caused by: com.sun.mail.smtp.SMTPSendFailedException: 250 2.0.0 v11L8poI023794 Message accepted for delivery
;
nested exception is:
com.sun.mail.smtp.SMTPAddressFailedException: 550 5.1.1 <address>... User unknown

Environment

Resolution

Causes:

  • Invalid email address

  • Default email address not configured yet nobody@nowhere hasn’t been changed

  • SMTP server is blocking the mail send somehow

Check Manage Jenkins  Configure System -  Jenkins Location - System Admin e-mail address

Invalid email address

Confirm that you can send emails manually to this address

Default email address not configured yet nobody@nowhere hasn’t been changed

This is the default when no system email address is set.

An example of an error when this is the issue:

Caused by: com.sun.mail.smtp.SMTPSendFailedException: 250 2.0.0 v11L8poI023794 Message accepted for delivery
;
nested exception is:
com.sun.mail.smtp.SMTPAddressFailedException: 550 5.1.1 <address>... User unknown
;
nested exception is:
com.sun.mail.smtp.SMTPAddressFailedException: 550 5.1.1 <not>... User unknown
;
nested exception is:
com.sun.mail.smtp.SMTPAddressFailedException: 550 5.1.1 <configured>... User unknown
;
nested exception is:
com.sun.mail.smtp.SMTPAddressFailedException: 550 5.1.1 <yet>... User unknown

at com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTransport.java:1112)
at javax.mail.Transport.send0(Transport.java:195)
at javax.mail.Transport.send(Transport.java:124)
at com.cloudbees.jenkins.plugin.metrics.views.Alerter$EmailRecipient.sendNotification(Alerter.java:2011)
... 5 more
Caused by: com.sun.mail.smtp.SMTPAddressFailedException: 550 5.1.1 <address>... User unknown
;
nested exception is:
com.sun.mail.smtp.SMTPAddressFailedException: 550 5.1.1 <not>... User unknown
;
nested exception is:
com.sun.mail.smtp.SMTPAddressFailedException: 550 5.1.1 <configured>... User unknown
;

SMTP server is blocking the mail send somehow

This can be caused by SMTP administrative settings. Contact your SMTP server administrator.

This article is part of our Knowledge Base and is provided for guidance-based purposes only. The solutions or workarounds described here are not officially supported by CloudBees and may not be applicable in all environments. Use at your own discretion, and test changes in a safe environment before applying them to production systems.