After updating plugins on either the CJOC or the controller, the controller will no longer connect to the CJOC

1 minute read

Issue

I am seeing one or multiple of my controllers disconnected with the CJOC due to this error:

java.lang.NoSuchMethodError: com.ning.http.client.AsyncHttpClientConfig$Builder.setFollowRedirects(Z)Lcom/ning/http/client/AsyncHttpClientConfig$Builder;
at com.cloudbees.opscenter.agent.AgentProtocolEndpointLocator.locate(AgentProtocolEndpointLocator.java:385)
at com.cloudbees.opscenter.client.plugin.OperationsCenterRegistrar$PushRegistrationConfirmation.<init>(OperationsCenterRegistrar.java:500)

Cause

During the plugin update one of the sides (either the CJOC or controller) had the Asynch HTTP Client plugin updated and now they do not connect correctly.

Resolution

You will need to look at the version difference between the CJOC and controller and either upgrade the lower one or downgrade/restore from a backup on the updated plugin version. Luckily this plugin does not modify too much setting and job code so a downgrade is relatively safe from previous experience.