CloudBees Jenkins Platform Operations Center 2.176.4.3

+

RELEASED: Public: 2019-09-25

Based on Jenkins LTS2.176.4-cb-3

Rolling release[.badge .badge-pill .ml-1 .badge-warning]Security release

Verified plugins

  • Async Http Client

    1.7.24.2 verified installed by default

  • Authentication Tokens API Plugin

    1.3 verified optional

  • Config File Provider Plugin

    3.5 verified optional

  • Credentials Binding Plugin

    1.20 verified optional

  • Credentials Plugin

    2.3.0 verified installed by default

  • Display URL API

    2.3.1 verified installed by default

  • Folders Plugin

    6.9 verified installed by default

  • JUnit Plugin

    1.28 verified installed by default

  • Jackson 2 API Plugin

    2.9.9.1 verified installed by default

  • Javadoc Plugin

    1.5 verified optional

  • Jenkins Mailer Plugin

    1.26 verified installed by default

  • Jenkins SSH Slaves plugin

    1.30.0 verified optional

  • LDAP Plugin

    1.20 verified optional

  • MapDB API Plugin

    1.0.9.0 verified installed by default

  • Metrics Plugin

    4.0.2.5 verified installed by default

  • OWASP Markup Formatter Plugin

    1.6 verified optional

  • Plain Credentials Plugin

    1.5 verified optional

  • SAML Plugin

    1.1.2 verified optional

  • SCM API Plugin

    2.6.3 verified installed by default

  • SSH Credentials Plugin

    1.17.1 verified optional

  • Script Security Plugin

    1.63 verified installed by default

  • Secure Requester Whitelist Plugin

    1.2 verified optional

  • Structs Plugin

    1.20 verified installed by default

  • Token Macro Plugin

    2.8 verified installed by default

  • Variant Plugin

    1.3 verified installed by default

Proprietary plugins

  • Beekeeper Upgrade Assistant Plugin

    2.138.0.10 proprietary installed by default

  • CloudBees Administrative Monitors Plugin

    1.0.1 proprietary installed by default

  • CloudBees Backup Plugin

    3.38.14 proprietary optional

  • CloudBees Folders Plus Plugin

    3.8 proprietary installed by default

  • CloudBees High Availability Management plugin

    4.20 proprietary installed by default

  • CloudBees Jenkins Advisor Plugin

    2.9 proprietary optional

  • CloudBees Jenkins Enterprise License Entitlement Check

    8.23 proprietary installed by default

  • CloudBees License Manager

    9.35 proprietary installed by default

  • CloudBees Monitoring Plugin

    2.8 proprietary installed by default

  • CloudBees Nodes Plus Plugin

    1.17 proprietary optional

  • CloudBees Plugin Usage Plugin

    1.10 proprietary optional

  • CloudBees Quiet Start Plugin

    1.5 proprietary optional

  • CloudBees Restart Aborted Builds Plugin

    1.12 proprietary optional

  • CloudBees Role-Based Access Control Plugin

    5.27 proprietary optional

  • CloudBees SSH Build Agents Plugin

    2.3 proprietary optional

  • CloudBees Skip Next Build Plugin

    4.2 proprietary optional

  • CloudBees Support Plugin

    3.22 proprietary installed by default

  • CloudBees Update Center Data API

    4.42 proprietary installed by default

  • CloudBees Update Center Plugin

    4.46 proprietary optional

  • CloudBees VMWare Autoscaling Plugin

    4.3.8 proprietary optional

  • CloudBees WikiText Security Plugin

    3.9 proprietary optional

  • External Notification Plugin

    1.2 proprietary optional

  • Notification API

    1.2 proprietary optional

  • Operations Center Agent

    2.176.0.1 proprietary installed by default

  • Operations Center Analytics

    2.107.1.5 proprietary optional

  • Operations Center Analytics Configuration

    2.107.1.5 proprietary optional

  • Operations Center Analytics Feeder

    2.107.1.5 proprietary optional

  • Operations Center Analytics Kibana Dashboards

    2.107.1.5 proprietary optional

  • Operations Center Analytics Reporter

    2.107.1.5 proprietary optional

  • Operations Center Analytics Viewer

    2.107.1.5 proprietary optional

  • Operations Center Context

    2.176.0.6 proprietary installed by default

  • Operations Center Elasticsearch Provider

    2.176.0.1 proprietary optional

  • Operations Center Embedded elasticsearch

    2.73.0.1 proprietary optional

  • Operations Center JNLP Agent Controller Plugin

    2.176.0.2 proprietary optional

  • Operations Center Monitoring Plugin

    2.176.0.1 proprietary optional

  • Operations Center Notification

    1.0 proprietary optional

  • Operations Center Server Cluster Operations

    2.176.0.1 proprietary optional

  • Operations Center Server EC2 Cloud

    2.176.0.1 proprietary optional

  • Operations Center Server License Entitlement Check

    2.176.0.1 proprietary installed by default

  • Operations Center Server Plugin

    2.176.0.6 proprietary installed by default

  • Operations Center Server Role Based Access Control

    2.176.0.1 proprietary optional

  • Operations Center Single Sign-On Plugin

    2.176.0.1 proprietary optional

  • Operations Center Update Center Plugin

    2.176.0.1 proprietary optional

  • User Activity Monitoring Plugin

    1.1.5 proprietary optional

Compatible plugins

  • Amazon EC2 plugin

    1.42.1 compatible optional

  • Amazon Web Services SDK

    1.11.562 compatible optional

  • CloudBees AWS Credentials Plugin

    1.27 compatible optional

  • CloudBees Flow

    1.1.9 compatible optional

  • Command Agent Launcher Plugin

    1.2 compatible installed by default

  • Durable Task Plugin

    1.30 compatible optional

  • Email Extension Plugin

    2.66 compatible optional

  • JAXB plugin

    2.3.0.1 compatible installed by default

  • Jenkins Active Directory plugin

    2.13 compatible optional

  • Jenkins Apache HttpComponents Client 4.x API Plugin

    4.5.5-3.0 compatible installed by default

  • Jenkins JSch dependency plugin

    0.1.55 compatible optional

  • Matrix Authorization Strategy Plugin

    2.4.2 compatible optional

  • Matrix Project Plugin

    1.14 compatible optional

  • Maven Integration plugin

    3.4 compatible optional

  • Node Iterator API Plugin

    1.5.0 compatible installed by default

  • Oracle Java SE Development Kit Installer Plugin

    1.3 compatible installed by default

  • PAM Authentication plugin

    1.4.1 compatible optional

  • Pipeline: API

    2.36 compatible installed by default

  • Pipeline: Step API

    2.20 compatible installed by default

  • SSH Agent Plugin

    1.17 compatible optional

  • Stack Trace Suppression Plugin

    1.5 compatible optional

  • Support Core Plugin

    2.60 compatible installed by default

  • Unique ID Library Plugin

    2.1.3 compatible optional

  • bouncycastle API Plugin

    2.17 compatible installed by default

Plugin modifications

  • Jenkins OSS LTS 2.176.4-cb-3

    Upgraded Jenkins OSS LTS from 2.176.3-cb-6 to 2.176.4-cb-3

  • Release Notes

    Upgraded OWASP Markup Formatter Plugin from 1.5 to 1.6

  • Release Notes

    Upgraded CloudBees Assurance Plugin from 2.138.0.8 to 2.138.0.10

  • Release Notes

    Upgraded CloudBees License Manager from 9.34 to 9.35

  • User-scoped credentials (JENSEC-526)

    Upgraded Credentials Plugin from 2.2.0 to 2.3.0. Global and folder credentials were too broadly accessible for certain pipeline use cases, and user credentials were not well supported by pipelines. User-scoped credentials associate credentials to users with manual unlocking of these credentials so that sensitive credentials can be isolated to trusted phases of pipelines and to trusted users.

  • Release Notes

    Upgraded Mailer Plugin from 1.23 to 1.26

  • Release Notes

    Upgraded Operations Center Server Plugin from 2.176.0.4 to 2.176.0.6

  • Release Notes

    Upgraded Plain Credentials Plugin from 1.4 to 1.5

  • Release Notes

    Upgraded Variant Plugin from 1.2 to 1.3

  • User-scoped credentials updates (JENSEC-495)

    The Pipeline Input Step plugin has been updated to support the new Credentials API for binding credentials parameters to builds and supports user credentials as well as credential parameter name shadowing.

  • Support Internet Explorer 11 (NGPIPELINE-619)

    The Pipeline Stage View plugin now supports Internet Explorer 11.