JDK Installer Not Showing Dropdown List

Article ID:215170338
1 minute readKnowledge base

Issue

  • JDK Installer for java.sun.com displays a text field instead of a dropdown list

  • Cannot use JDK Installer

Environment

  • CloudBees Jenkins Enterprise

Root cause

This is a problems of the basic function of the update center. The update center does not fetch the latest data file for the JDK Installer.

Resolution

This can be fixed inside a running instance of CJE.

Delete the failing JDK installers

  1. Got to Manage Jenkins/Configure System

  2. Remove the JDK installer image::common-kb::jdkinstaller-conf-dropdown.png[image-1.png]

Force Jenkins to update the JDK Installer data file:

  1. Go to Manage Jenkins/Script Console

  2. Copy/Paste and Run this groovy script that will update the data file for tools and installers:

      hudson.model.DownloadService.signatureCheck = false
      hudson.model.DownloadService.Downloadable.get("hudson.tools.JDKInstaller").updateNow()
      hudson.model.DownloadService.signatureCheck = true
      return
  3. The script might take few seconds to finish. A label Result appears below the Text Area indicating that the script has run. image::common-kb::jdkinstaller-conf-no-dropdown.png[image-2.png]

    This line should appears in the log as well:

     ...
     INFO: Obtained the updated data file for hudson.tools.JDKInstaller
     ...
  4. Go to Manage Jenkins/Configure System

  5. Add a JDK Installation and select the java.sun.com JDK Installer. There should be a dropdown list. image::common-kb::jdkinstaller-script-result.png[image-3.png]

This article is part of our Knowledge Base and is provided for guidance-based purposes only. The solutions or workarounds described here are not officially supported by CloudBees and may not be applicable in all environments. Use at your own discretion, and test changes in a safe environment before applying them to production systems.