EC6006

Synopsis

ERROR: EC6006 - Errors during EFS compilation.

Description

It was not possible to compile the “Electric File System” (EFS) driver on Linux. On Windows agents, the EFS driver failed to install.

Reasons

Common reasons for this error are: - the attempt to install on an unsupported version of Linux - ‘gcc’ or ‘make’ is not installed - the kernel development packages are missing - the version of gcc doesn’t match the one which was used to build the running kernel.

Fixes

Install the ‘gcc’, ‘make’ if you don’t have them, otherwise update them using your package management tool. Update your distribution’s kernel to ensure that it matches your up-to-date gcc. Install the ‘linux-headers’ on Ubuntu, ‘kernel-devel’ packages on RedHat/Fedora. Examine the install log for a full description of the error and communicate it to CB support.