CloudBees CI on traditional platforms - Operations Center 2.190.2.2

Rolling release: 2019-09-25

Based on Jenkins LTS 2.190.2-cb-5

Initial release

Verified plugins

  • Async Http Client

    1.7.24.2 verifiedinstalled by default

  • Authentication Tokens API Plugin

    1.3 verifiedoptional

  • Config File Provider Plugin

    3.6.2 verifiedoptional

  • Credentials Binding Plugin

    1.20 verifiedoptional

  • Credentials Plugin

    2.3.0 verifiedinstalled by default

  • Display URL API

    2.3.1 verifiedinstalled by default

  • Folders Plugin

    6.9 verifiedinstalled by default

  • JUnit Plugin

    1.28 verifiedinstalled by default

  • Jackson 2 API Plugin

    2.9.10 verifiedinstalled by default

  • Javadoc Plugin

    1.5 verifiedoptional

  • Jenkins Mailer Plugin

    1.29 verifiedinstalled by default

  • Jenkins SSH Slaves plugin

    1.30.2 verifiedoptional

  • LDAP Plugin

    1.20 verifiedoptional

  • MapDB API Plugin

    1.0.9.0 verifiedinstalled by default

  • Metrics Plugin

    4.0.2.6 verifiedinstalled by default

  • OWASP Markup Formatter Plugin

    1.6 verifiedoptional

  • Plain Credentials Plugin

    1.5 verifiedoptional

  • SAML Plugin

    1.1.2 verifiedoptional

  • SCM API Plugin

    2.6.3 verifiedinstalled by default

  • SSH Credentials Plugin

    1.17.3 verifiedoptional

  • Script Security Plugin

    1.66 verifiedinstalled by default

  • Secure Requester Whitelist Plugin

    1.4 verifiedoptional

  • Structs Plugin

    1.20 verifiedinstalled by default

  • Token Macro Plugin

    2.8 verifiedinstalled by default

  • Variant Plugin

    1.3 verifiedinstalled by default

Proprietary plugins

  • Beekeeper Upgrade Assistant Plugin

    2.138.0.10 proprietaryinstalled by default

  • CloudBees Administrative Monitors Plugin

    1.0.1 proprietaryinstalled by default

  • CloudBees Analytics Plugin

    1.2 proprietaryinstalled by default

  • CloudBees Backup Plugin

    3.38.14 proprietaryoptional

  • CloudBees Folders Plus Plugin

    3.8 proprietaryinstalled by default

  • CloudBees High Availability Management plugin

    4.20 proprietaryinstalled by default

  • CloudBees Jenkins Advisor Plugin

    2.9 proprietaryoptional

  • CloudBees Jenkins Enterprise License Entitlement Check

    8.24 proprietaryinstalled by default

  • CloudBees License Manager

    9.35 proprietaryinstalled by default

  • CloudBees Monitoring Plugin

    2.8 proprietaryinstalled by default

  • CloudBees Nodes Plus Plugin

    1.17 proprietaryoptional

  • CloudBees Plugin Usage Plugin

    1.10 proprietaryoptional

  • CloudBees Quiet Start Plugin

    1.5 proprietaryoptional

  • CloudBees Restart Aborted Builds Plugin

    1.12 proprietaryoptional

  • CloudBees Role-Based Access Control Plugin

    5.27 proprietaryoptional

  • CloudBees SSH Build Agents Plugin

    2.3 proprietaryoptional

  • CloudBees Skip Next Build Plugin

    4.2 proprietaryoptional

  • CloudBees Support Plugin

    3.22 proprietaryinstalled by default

  • CloudBees Update Center Data API

    4.42 proprietaryinstalled by default

  • CloudBees Update Center Plugin

    4.46 proprietaryoptional

  • CloudBees VMWare Autoscaling Plugin

    4.3.8 proprietaryoptional

  • CloudBees WikiText Security Plugin

    3.9 proprietaryoptional

  • External Notification Plugin

    1.2 proprietaryoptional

  • Notification API

    1.2 proprietaryoptional

  • Operations Center Agent

    2.190.0.1 proprietaryinstalled by default

  • Operations Center Analytics

    2.107.1.5 proprietaryoptional

  • Operations Center Analytics Configuration

    2.107.1.5 proprietaryoptional

  • Operations Center Analytics Feeder

    2.107.1.5 proprietaryoptional

  • Operations Center Analytics Kibana Dashboards

    2.107.1.5 proprietaryoptional

  • Operations Center Analytics Reporter

    2.107.1.5 proprietaryoptional

  • Operations Center Analytics Viewer

    2.107.1.5 proprietaryoptional

  • Operations Center Context

    2.190.0.1 proprietaryinstalled by default

  • Operations Center Elasticsearch Provider

    2.190.0.1 proprietaryoptional

  • Operations Center Embedded elasticsearch

    2.73.0.1 proprietaryoptional

  • Operations Center JNLP Agent Controller Plugin

    2.190.0.1 proprietaryoptional

  • Operations Center Monitoring Plugin

    2.190.0.1 proprietaryoptional

  • Operations Center Notification

    1.0 proprietaryoptional

  • Operations Center Server Cluster Operations

    2.190.0.1 proprietaryoptional

  • Operations Center Server EC2 Cloud

    2.190.0.1 proprietaryoptional

  • Operations Center Server License Entitlement Check

    2.190.0.1 proprietaryinstalled by default

  • Operations Center Server Plugin

    2.190.0.2 proprietaryinstalled by default

  • Operations Center Server Role Based Access Control

    2.190.0.1 proprietaryoptional

  • Operations Center Single Sign-On Plugin

    2.190.0.1 proprietaryoptional

  • Operations Center Update Center Plugin

    2.190.0.1 proprietaryoptional

  • User Activity Monitoring Plugin

    1.1.5 proprietaryoptional

Compatible plugins

  • Amazon EC2 plugin

    1.46.1 compatibleoptional

  • Amazon Web Services SDK

    1.11.594 compatibleoptional

  • CloudBees AWS Credentials Plugin

    1.27 compatibleoptional

  • CloudBees Flow

    1.1.10 compatibleoptional

  • Command Agent Launcher Plugin

    1.3 compatibleinstalled by default

  • Durable Task Plugin

    1.30 compatibleoptional

  • Email Extension Plugin

    2.66 compatibleoptional

  • JAXB plugin

    2.3.0.1 compatibleinstalled by default

  • Jenkins Active Directory plugin

    2.16 compatibleoptional

  • Jenkins Apache HttpComponents Client 4.x API Plugin

    4.5.10-1.0 compatibleinstalled by default

  • Jenkins JSch dependency plugin

    0.1.55.1 compatibleoptional

  • Matrix Authorization Strategy Plugin

    2.4.2 compatibleoptional

  • Matrix Project Plugin

    1.14 compatibleoptional

  • Maven Integration plugin

    3.4 compatibleoptional

  • Node Iterator API Plugin

    1.5.0 compatibleinstalled by default

  • Oracle Java SE Development Kit Installer Plugin

    1.3 compatibleinstalled by default

  • PAM Authentication plugin

    1.4.1 compatibleoptional

  • Pipeline: API

    2.37 compatibleinstalled by default

  • Pipeline: Step API

    2.20 compatibleinstalled by default

  • SSH Agent Plugin

    1.17 compatibleoptional

  • Stack Trace Suppression Plugin

    1.5 compatibleoptional

  • Support Core Plugin

    2.60 compatibleinstalled by default

  • Trilead API Plugin

    1.0.4 compatibleoptional

  • Unique ID Library Plugin

    2.2.0 compatibleoptional

  • bouncycastle API Plugin

    2.17 compatibleinstalled by default

Plugin modifications

  • Jenkins LTS 2.190.2-cb-5

    Upgraded Jenkins LTS from 2.176.4-cb-3 to 2.190.2-cb-5

  • Release Notes

    Upgraded Active Directory Plugin from 2.13 to 2.16

  • Release Notes

    Upgraded Apache HttpComponents Client 4.x API Plugin from 4.5.5-3.0 to 4.5.10-1.0

  • Release Notes

    Upgraded Amazon Web Services SDK library from 1.11.562 to 1.11.594

  • Release Notes

    Upgraded Command Agent Launcher Plugin from 1.2 to 1.3

  • Release Notes

    Upgraded Config File Provider Plugin from 3.5 to 3.6.2

  • Release Notes

    Upgraded Amazon EC2 Plugin from 1.42.1 to 1.46.1

  • Release Notes

    Upgraded CloudBees Flow from 1.1.9 to 1.1.10

  • Release Notes

    Upgraded JSch Plugin from 0.1.55 to 0.1.55.1

  • Release Notes

    Upgraded Mailer Plugin from 1.26 to 1.29

  • Release Notes

    Upgraded Metrics Plugin from 4.0.2.5 to 4.0.2.6

  • Release Notes

    Upgraded CloudBees Jenkins Enterprise License Entitlement Check from 8.23 to 8.24

  • Release Notes

    Upgraded Operations Center Agent Plugin from 2.176.0.1 to 2.190.0.1

  • Release Notes

    Upgraded Operations Center Cluster Operations Plugin from 2.176.0.1 to 2.190.0.1

  • Release Notes

    Upgraded Operations Center EC2 Cloud Plugin from 2.176.0.1 to 2.190.0.1

  • Release Notes

    Upgraded Operations Center Elasticsearch Provider Plugin from 2.176.0.1 to 2.190.0.1

  • Release Notes

    Upgraded Operations Center JNLP Agent Controller Plugin from 2.176.0.2 to 2.190.0.1

  • Release Notes

    Upgraded Operations Center License Entitlement Check from 2.176.0.1 to 2.190.0.1

  • Release Notes

    Upgraded Operations Center Monitoring Plugin from 2.176.0.1 to 2.190.0.1

  • Release Notes

    Upgraded Operations Center RBAC Plugin from 2.176.0.1 to 2.190.0.1

  • Release Notes

    Upgraded Operations Center Server Plugin from 2.176.0.6 to 2.190.0.2

  • Release Notes

    Upgraded Operations Center Single Sign-On Plugin from 2.176.0.1 to 2.190.0.1

  • Release Notes

    Upgraded Operations Center Update Center Plugin from 2.176.0.1 to 2.190.0.1

  • Compatibility with JCasC (JENSEC-603)

    Upgraded Secure Requester Whitelist Plugin from 1.2 to 1.4 and added compatibility with the Jenkins Configuration as Code Plugin.

  • Release Notes

    Upgraded SSH Slaves Plugin from 1.30.0 to 1.30.2

  • Release Notes

    Upgraded Unique ID Plugin from 2.1.3 to 2.2.0

  • Release Notes

    Upgraded Pipeline API Plugin from 2.36 to 2.37

  • Release Notes

    Added CloudBees Analytics Plugin version 1.2

  • Release Notes

    Added Trilead API Plugin version 1.0.4

  • Update for 2.9.10 (JENSEC-533)

    Upgraded Jackson2 API Plugin from 2.9.9.1 to 2.9.10. Previous releases of Jackson were vulnerable to numerous CVEs listed in

  • https://github.com/FasterXML/jackson/wiki/Jackson-Release-2.9.10#databind which are fixed in this release.

  • Fix Copy with Builds error (CTR-680)

    Upgraded Operations Center Context Plugin from 2.176.0.6 to 2.190.0.1. Maven jobs could not be moved/copied using the Move/Copy/Promote feature. With this fix, there is a new file (permalinks) inside the builds folder which is autogenerated by Jenkins core, and the Move/Copy operations are overwriting it now.

  • Update to 1.66 (NGPIPELINE-745, -741)

    Upgraded Script Security Plugin from 1.63 to 1.66. A cache used by the class loader for sandboxed Groovy scripts was cleared out every time the garbage collector ran. This clearing out could lead to performance issues for complex sandboxed scripts, particularly in environments where the garbage collector ran frequently, as it significantly reduced the effectiveness of the cache. The cache used by the class loader for sandboxed Groovy scripts is no longer cleared out by the garbage collector.

  • SSH keys issue (JENSEC-639)

    Upgraded SSH Credentials Plugin from 1.17.1 to 1.17.3. SSH keys saved as credentials without a new line at the end of the key caused errors with downstream consumers of the SSH keys. With this fix, SSH keys saved as credentials without a new line at the end of the key now work as expected.