Issue
When trying to edit the System Configuration (Manage Jenkins > System) on my controller, the Save and Apply buttons are not visible at the bottom of the page, preventing any changes made to the configuration to be saved.
Root Cause
The Propelo’s Job Reporter plugin interferes with the System Configuration page layout when installed on any version of CloudBees CI controller instance causing the Save and Apply buttons to be omitted from the generated HTML, preventing configuration edits.
Resolution
To resolve this issue, you have the following options:
-
If you plan to use this plugin, please update the version to 1.0.36 or later and restart the controller instance. This resolves the issue bringing back the Save and Apply buttons on the System Configuration page allowing you to save your changes.
-
If you do not use this plugin, please disable or uninstall the plugin from your controller instance.
Tested product/plugin versions
-
CloudBees CI on modern cloud platforms - managed controller 2.452.1.2
-
CloudBees CI on modern cloud platforms - managed controller 2.504.2.5
-
CloudBees CI on traditional platforms - client controller 2.504.2.5
-
CloudBees CI on traditional platforms - client controller 2.452.1.2
-
Propelo’s Job Reporter 1.0.33
-
Propelo’s Job Reporter 1.0.35