Windows Platform Prerequisites

This section describes the Cluster Manager, eMake, and Electric Agent/EFS installation prerequisites on Windows platforms.

For information about platform support such as operating systems, cloud-based and Kubernetes support, Make versions, eMake emulation, databases, bitnesses, and Visual Studio versions, see CloudBees Accelerator Supported Platforms.

Windows Installation Prerequisites

  • Each host to run Accelerator software must be x86-64 compatible (except for the supported 32-bit systems listed above, which must be x86 compatible).

  • NTFS is required.

  • Registry mirroring is supported on 64-bit machines only if you use 64-bit eMake and 64-bit agents.

Service Pack and Redistributables Prerequisites

The Accelerator installer automatically installs the Visual Studio 2005 Service Pack 1 Update and the Microsoft Visual C++ 2010 Redistributable Package (x86) if they are not already installed. These are required for running eMake with Visual Studio.