Web Browser Requirements

To connect to the Cluster Manager, you must use one of the following web browsers.

Desktop Browsers

  • Chrome 43 or newer

  • Firefox 31.8 or newer

  • Internet Explorer 10 or newer

Mobile Browsers

  • Chrome on Android 4.4 (KitKat) or newer

  • Internet Explorer Mobile 11 or newer

  • iOS 7 or newer