Solaris Platform Prerequisites

On this page

This section describes the Cluster Manager, eMake, and Electric Agent/EFS installation prerequisites on Solaris platforms.

For information about platform support such as operating systems, cloud-based and Kubernetes support, Make versions, eMake emulation, databases, bitnesses, and Visual Studio versions, see CloudBees Accelerator Supported Platforms.

Solaris Prerequisites

For Solaris x86, eMake uses several third-party open-source libraries. The version of libxml2 that Electric Cloud builds in-house differs from the version that is available on SunFreeware.com. If you run eMake and get an error such as:

ld.so.1: emake: fatal: libxml2.so.2: version `LIBXML2_2.7.6' not found (required by file /opt/ecloud/i686_SunOS.5.10/bin/emake) ld.so.1: emake: fatal: libxml2.so.2: open failed: No such file or directory

then your LD_LIBRARY_PATH environment variable contains a directory that includes a version of libxml2.so.2 that is probably incompatible with eMake. Unset LD_LIBRARY_PATH entirely to make eMake’s rpath find the necessary libraries.