Using Eclipse with CloudBees Accelerator

1 minute read

To configure Eclipse to run eMake, follow this procedure:

  1. Open your C++ project.

  2. Go to the project’s Properties > Builders and click New.

  3. Select Program and click OK.

  4. Fill in the following information for the new builder under the Main tab:

    • Name

    • Location (the full path to emake, which is OS dependent)

    • Working Directory

    • Arguments (arguments are specific to your configuration)

The following screenshot illustrates the Edit Configuration dialog.

  1. Click the Build Options tab. Enable Run the builder for the following only :

    • After a “Clean”

    • During manual builds

    • During auto builds

  2. Click OK. Your new builder is displayed in the Builders pane.

  3. Create another builder for “cleans” only. On its Main tab, ensure clean is included for Arguments . On its Build Options tab, enable Run the builder for the following only :

    • During a “Clean”

  4. Click OK. Your second builder is displayed in the Builders pane.

  5. Deselect CDT Builder in the Builders pane and then click OK.

Now you can build your project. Click Project > Build all.

The following screenshot illustrates a build in progress.

The following screenshot illustrates a successfully completed build.