System Requirements

Supported Visual Studio Versions

The Visual Studio IDE Integration supports the following versions of Visual Studio:

  • Visual Studio 2019 (all editions) for builds invoked from the Visual Studio IDE extension. (Command-line builds, which use ecdevenv and the Visual Studio Converter Extension, do not support Visual Studio 2019)

  • Visual Studio 2017 (all editions)

  • Visual Studio 2015

  • Visual Studio 2013

  • Visual Studio 2012

  • Visual Studio 2010

  • Visual Studio 2008

  • Visual Studio 2005 (command-line only)

The Visual Studio IDE Converter for Visual Studio 2010 or later does not support Xbox builds, Windows Mobile configurations, or custom build rules.

Prerequisites

MSBuild Prerequisites

The IDE converter cannot virtualize the MSBuild utility. If you are virtualizing your toolchain, you might need to install the following packages for your version of Visual Studio on every agent host in your cluster.

Visual Studio Version Packages

2019

*.NET Framework 4.6.2 * MSBuild Tools 15.0 * Visual C++ Build Tools 15.0

2017

2015

*.NET Framework 4.6 * Microsoft Build Tools 2015

2013

*.NET Framework 4.5 * Microsoft Build Tools 2013

2012

2010

2008

2005

If you do not virtualize your toolchain, you must install Visual Studio on each agent host in your cluster.

Visual Studio IDE Extension Prerequisites

The Visual Studio IDE extension requires:

  • Accelerator installed on the build machine

  • (Visual Studio 2015 and earlier) .NET Framework v3.5

  • (Visual Studio 2017 and later) .NET Framework v4.6

Visual Studio Converter Extension Prerequisites

The Visual Studio Converter Extension requires:

  • Microsoft Visual C++ 2017 Redistributable Package. (This package is installed automatically as part of the extension.) *.NET Framework v2.0

  • (If using Visual Studio 2005 Service Pack 1) Microsoft hotfix that is described in Microsoft Knowledge Base articles 933054 and 934517. Without the hotfix, the Visual Studio Converter Add-In will not function correctly, which means that ecdevenv is not called, so builds will not be accelerated.

    For download information, see the Visual Studio 2005 behaves as if the Visual Studio Add-in is not installed article on the CloudBees “Ask” website.

The Visual Studio Converter Extension does not support Visual Studio 2019.

ecdevenv Utility Prerequisites

The ecdevenv utility requires:

  • Visual Studio Converter Extension

  • .NET Framework v4.0

The ecdevenv utility does not support Visual Studio 2019.

Electrify Utility Prerequisites

The Electrify utility requires the Microsoft Visual C++ 2005 SP1 Redistributable Package.